summaryrefslogtreecommitdiff
path: root/rodion/packages/patches/0001-fallout2-ce-fpattern.patch
diff options
context:
space:
mode:
authorRodion Goritskov <rodion.goritskov@gmail.com>2024-06-03 21:09:55 +0400
committerRodion Goritskov <rodion.goritskov@gmail.com>2024-06-03 21:09:55 +0400
commit394cf8f71aef45ad2529fa889690d76cbe2fbbb1 (patch)
tree6b937e7503940988864550e8205ac35d88b9edbd /rodion/packages/patches/0001-fallout2-ce-fpattern.patch
parentf71bfbf250ae2730691be78b62583b9607f6b923 (diff)
parent0130f144e8d7690a5b08118f402aa7a6be613902 (diff)
Merge branch 'master' of ssh://ssh.goritskov.com:10022/rodion/little-guix-channel
Diffstat (limited to 'rodion/packages/patches/0001-fallout2-ce-fpattern.patch')
-rw-r--r--rodion/packages/patches/0001-fallout2-ce-fpattern.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/rodion/packages/patches/0001-fallout2-ce-fpattern.patch b/rodion/packages/patches/0001-fallout2-ce-fpattern.patch
new file mode 100644
index 0000000..6c58e7e
--- /dev/null
+++ b/rodion/packages/patches/0001-fallout2-ce-fpattern.patch
@@ -0,0 +1,14 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 2de2af1..f6c6ace 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -360,7 +360,8 @@ if(APPLE)
+ set(MACOSX_BUNDLE_BUNDLE_VERSION "1.3.0")
+ endif()
+
+-add_subdirectory("third_party/fpattern")
++find_library(FPATTERN_LIBRARY libfpattern.so)
++find_path(FPATTERN_INCLUDE_DIR fpattern.h)
+ target_link_libraries(${EXECUTABLE_NAME} ${FPATTERN_LIBRARY})
+ target_include_directories(${EXECUTABLE_NAME} PRIVATE ${FPATTERN_INCLUDE_DIR})
+