summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRodion Goritskov <rodion.goritskov@gmail.com>2024-06-03 21:09:55 +0400
committerRodion Goritskov <rodion.goritskov@gmail.com>2024-06-03 21:09:55 +0400
commit394cf8f71aef45ad2529fa889690d76cbe2fbbb1 (patch)
tree6b937e7503940988864550e8205ac35d88b9edbd
parentf71bfbf250ae2730691be78b62583b9607f6b923 (diff)
parent0130f144e8d7690a5b08118f402aa7a6be613902 (diff)
Merge branch 'master' of ssh://ssh.goritskov.com:10022/rodion/little-guix-channel
-rw-r--r--rodion/packages/emacs.scm31
-rw-r--r--rodion/packages/fonts.scm3
-rw-r--r--rodion/packages/games.scm103
-rw-r--r--rodion/packages/go.scm39
-rw-r--r--rodion/packages/patches/0001-fallout-ce-fpattern.patch15
-rw-r--r--rodion/packages/patches/0001-fallout2-ce-fpattern.patch14
6 files changed, 184 insertions, 21 deletions
diff --git a/rodion/packages/emacs.scm b/rodion/packages/emacs.scm
index aa6acbf..d603c04 100644
--- a/rodion/packages/emacs.scm
+++ b/rodion/packages/emacs.scm
@@ -79,17 +79,20 @@ This package has been written to leverage tree-sitter parsing facilities, allowi
"LanguageTool is a free and open-source multilingual grammar, style, and spell checker with support for more than 30 languages. So, why not use it as your Emacs grammar and spell check tool. That is what this package is for.")
(license license:gpl3)))
-(define-public emacs-hyperbole-master
- (package
- (inherit emacs-hyperbole)
- (name "emacs-hyperbole")
- (version "8.0.1-6c5002e6")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.savannah.gnu.org/git/hyperbole.git")
- (commit "6c5002e67061f4cc51a7e5ab7a237880d55709c6")))
- (file-name (git-file-name name version))
- (sha256
- (base32 "01z8fci49wm1pgrgrvmw253q1jzs42ink4pbjg3gn6gjfng96h4l"))))))
+(define-public emacs-ox-gemini/latest
+ ;; No releases yet
+ (let ((commit "50818de823b7929f2d3207833e7c581280a60289")
+ (revision "2"))
+ (package
+ (inherit emacs-ox-gemini)
+ (name "emacs-ox-gemini")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~abrahms/ox-gemini")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1kaf3p6g46rvbiyrkfmpflhdvzz9bdqsq1m02496py92399x3knz")))))))
diff --git a/rodion/packages/fonts.scm b/rodion/packages/fonts.scm
index 2db6bbb..0081423 100644
--- a/rodion/packages/fonts.scm
+++ b/rodion/packages/fonts.scm
@@ -41,7 +41,6 @@
(description
"Font Awesome is a full suite of pictographic icons for easy scalable
vector graphics.")
- (license license:silofl1.1)
- ))
+ (license license:silofl1.1)))
diff --git a/rodion/packages/games.scm b/rodion/packages/games.scm
new file mode 100644
index 0000000..e81fe26
--- /dev/null
+++ b/rodion/packages/games.scm
@@ -0,0 +1,103 @@
+(define-module (rodion packages games)
+ #:use-module (guix packages)
+ #:use-module (guix build-system copy)
+ #:use-module (guix build-system cmake)
+ #:use-module (guix git-download)
+ #:use-module (guix gexp)
+ #:use-module (gnu packages sdl)
+ #:use-module (gnu packages compression)
+ #:use-module ((guix licenses) #:prefix license:))
+
+(define-public fpattern
+ (package
+ (name "fpattern")
+ (version "1.9")
+ (build-system copy-build-system)
+ (home-page "https://github.com/Loadmaster/fpattern")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Loadmaster/fpattern")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "0lm5afk18a6m4wib4xvslik9zz00r36zvdrrgjbwd8d8550cq2zx"))))
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'install 'build-library
+ (lambda* (#:key inputs #:allow-other-keys)
+ (invoke "gcc" "-c" "-Wall" "-fpic" "fpattern.c")
+ (invoke "gcc" "-shared" "-o" "libfpattern.so" "fpattern.o"))))
+ #:install-plan ''(("libfpattern.so" "lib/")
+ ("fpattern.h" "include/"))))
+ (license license:expat)
+ (description "Filename pattern matching library functions")
+ (synopsis "Filename pattern matching library functions for DOS, Windows, and Unix.
+
+Functions for matching filename patterns to filenames. Written in C. Provided as an object file (fpattern.obj) and a header include source file (fpattern.h).
+
+Filename patterns are composed of regular (printable) characters which may comprise a filename, as well as special pattern matching characters. A filename patterns is a special kind of regular expression, except that it is not as general and is designed to match only file and directory names instead of arbitrary text strings. The syntax is borrowed from Unix, and is a superset of the MS-DOS and Windows syntax.")))
+
+(define-public fallout-ce
+ (package
+ (name "fallout-ce")
+ (version "1.1.0")
+ (build-system cmake-build-system)
+ (home-page "https://github.com/alexbatalov/fallout1-ce")
+ (inputs (list sdl2
+ fpattern))
+ (arguments
+ (list
+ #:tests? #f
+ #:phases #~(modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (mkdir-p bin)
+ (copy-file "fallout-ce" (string-append bin "/fallout-ce"))))))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alexbatalov/fallout1-ce")
+ (commit (string-append "v" version))))
+ (patches `(,(local-file "./patches/0001-fallout-ce-fpattern.patch")))
+ (sha256
+ (base32 "0c11zbvja42s0z8zqfm6gf981m0v2vwxvhqas46lplwbfhbnh836"))))
+ (license license:expat)
+ (description "Fallout")
+ (synopsis "Fallout")))
+
+(define-public fallout2-ce
+ (package
+ (name "fallout2-ce")
+ (version "1.3.0")
+ (build-system cmake-build-system)
+ (home-page "https://github.com/alexbatalov/fallout2-ce")
+ (inputs (list sdl2
+ fpattern
+ zlib))
+ (arguments
+ (list
+ #:tests? #f
+ #:phases #~(modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (mkdir-p bin)
+ (copy-file "fallout2-ce" (string-append bin "/fallout2-ce"))))))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alexbatalov/fallout2-ce")
+ (commit (string-append "v" version))))
+ (patches `(,(local-file "./patches/0001-fallout2-ce-fpattern.patch")))
+ (sha256
+ (base32 "15b30i2ixq0w01qxrymd1qs1awj8kijbqzac8wvfrpm85fdnfnmg"))))
+ (license license:expat)
+ (description "Fallout")
+ (synopsis "Fallout")))
diff --git a/rodion/packages/go.scm b/rodion/packages/go.scm
index b0af61e..dcb4e16 100644
--- a/rodion/packages/go.scm
+++ b/rodion/packages/go.scm
@@ -70,6 +70,33 @@
(list go-1.21)
(package-native-inputs go-1.21)))))
+(define-public go-github-com-andybalholm-brotli-new
+ (package
+ (name "go-github-com-andybalholm-brotli-new")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/andybalholm/brotli")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zdvcwfzxnkljyh4p7izy0bfxrwidwwmp1p5h1fydyrgbs4xacly"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/andybalholm/brotli"))
+ (home-page "https://github.com/andybalholm/brotli")
+ (synopsis "Pure Go Brotli encoder and decoder")
+ (description
+ "This package is a brotli compressor and decompressor implemented in Go.
+It was translated from the reference implementation
+(@url{https://github.com/google/brotli,https://github.com/google/brotli}) with
+the @code{c2go} tool at
+@url{https://github.com/andybalholm/c2go,https://github.com/andybalholm/c2go}.")
+ (license license:expat)))
+
+
(define-public go-std-1.22 (make-go-std go-1.22))
(define-public go-github-com-x448-float16
@@ -344,7 +371,7 @@ implementation procedures outlined by the document.")
(define-public miniflux
(package
(name "miniflux")
- (version "2.1.2")
+ (version "2.1.3")
(source
(origin
(method git-fetch)
@@ -353,7 +380,7 @@ implementation procedures outlined by the document.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0mi0bqnw3y9b2akil1rd52jq59nijsal0w2zp8ll6br0pr4sic82"))))
+ (base32 "0cb0fkjzbjrhgmx1s8jv1drdgfaddkyj9j9z451qswgvz6xyp3a3"))))
(build-system go-build-system)
(arguments
(list
@@ -364,9 +391,10 @@ implementation procedures outlined by the document.")
"-ldflags= -X miniflux.app/v2/internal/version.Version="
#$version))
#:phases #~(modify-phases %standard-phases
- (add-before 'build 'disable-cgo
- (lambda _
- (setenv "CGO_ENABLED" "0")))
+ ;; Scans for all tests recursively
+ (replace 'check
+ (lambda* (#:key import-path #:allow-other-keys)
+ (invoke "go" "test" (string-append import-path "/..."))))
(add-after 'install 'install-manpage
(lambda* (#:key import-path #:allow-other-keys)
(let ((man1 (string-append #$output "/share/man/man1/"))
@@ -380,6 +408,7 @@ implementation procedures outlined by the document.")
(inputs (list go-github-com-go-webauthn-webauthn-webauthn
go-github-com-go-webauthn-webauthn-protocol
go-github-com-go-webauthn-webauthn-metadata
+ go-github-com-andybalholm-brotli-new
go-github-com-abadojack-whatlanggo
go-github-com-coreos-go-oidc-v3
go-github-com-gorilla-mux
diff --git a/rodion/packages/patches/0001-fallout-ce-fpattern.patch b/rodion/packages/patches/0001-fallout-ce-fpattern.patch
new file mode 100644
index 0000000..d2772c5
--- /dev/null
+++ b/rodion/packages/patches/0001-fallout-ce-fpattern.patch
@@ -0,0 +1,15 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index bd50a9e..afdb04c 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -353,7 +353,9 @@ else()
+ find_package(SDL2)
+ endif()
+
+-add_subdirectory("third_party/fpattern")
++find_path(FPATTERN_INCLUDE_DIR fpattern.h)
++find_library(FPATTERN_LIBRARY libfpattern.so)
++
+ target_link_libraries(${EXECUTABLE_NAME} ${FPATTERN_LIBRARY})
+ target_include_directories(${EXECUTABLE_NAME} PRIVATE ${FPATTERN_INCLUDE_DIR})
+
diff --git a/rodion/packages/patches/0001-fallout2-ce-fpattern.patch b/rodion/packages/patches/0001-fallout2-ce-fpattern.patch
new file mode 100644
index 0000000..6c58e7e
--- /dev/null
+++ b/rodion/packages/patches/0001-fallout2-ce-fpattern.patch
@@ -0,0 +1,14 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 2de2af1..f6c6ace 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -360,7 +360,8 @@ if(APPLE)
+ set(MACOSX_BUNDLE_BUNDLE_VERSION "1.3.0")
+ endif()
+
+-add_subdirectory("third_party/fpattern")
++find_library(FPATTERN_LIBRARY libfpattern.so)
++find_path(FPATTERN_INCLUDE_DIR fpattern.h)
+ target_link_libraries(${EXECUTABLE_NAME} ${FPATTERN_LIBRARY})
+ target_include_directories(${EXECUTABLE_NAME} PRIVATE ${FPATTERN_INCLUDE_DIR})
+