summaryrefslogtreecommitdiff
path: root/rodion/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'rodion/packages/patches')
-rw-r--r--rodion/packages/patches/0001-fallout-ce-fpattern.patch15
-rw-r--r--rodion/packages/patches/0001-fallout2-ce-fpattern.patch14
2 files changed, 29 insertions, 0 deletions
diff --git a/rodion/packages/patches/0001-fallout-ce-fpattern.patch b/rodion/packages/patches/0001-fallout-ce-fpattern.patch
new file mode 100644
index 0000000..d2772c5
--- /dev/null
+++ b/rodion/packages/patches/0001-fallout-ce-fpattern.patch
@@ -0,0 +1,15 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index bd50a9e..afdb04c 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -353,7 +353,9 @@ else()
+ find_package(SDL2)
+ endif()
+
+-add_subdirectory("third_party/fpattern")
++find_path(FPATTERN_INCLUDE_DIR fpattern.h)
++find_library(FPATTERN_LIBRARY libfpattern.so)
++
+ target_link_libraries(${EXECUTABLE_NAME} ${FPATTERN_LIBRARY})
+ target_include_directories(${EXECUTABLE_NAME} PRIVATE ${FPATTERN_INCLUDE_DIR})
+
diff --git a/rodion/packages/patches/0001-fallout2-ce-fpattern.patch b/rodion/packages/patches/0001-fallout2-ce-fpattern.patch
new file mode 100644
index 0000000..6c58e7e
--- /dev/null
+++ b/rodion/packages/patches/0001-fallout2-ce-fpattern.patch
@@ -0,0 +1,14 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 2de2af1..f6c6ace 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -360,7 +360,8 @@ if(APPLE)
+ set(MACOSX_BUNDLE_BUNDLE_VERSION "1.3.0")
+ endif()
+
+-add_subdirectory("third_party/fpattern")
++find_library(FPATTERN_LIBRARY libfpattern.so)
++find_path(FPATTERN_INCLUDE_DIR fpattern.h)
+ target_link_libraries(${EXECUTABLE_NAME} ${FPATTERN_LIBRARY})
+ target_include_directories(${EXECUTABLE_NAME} PRIVATE ${FPATTERN_INCLUDE_DIR})
+