summaryrefslogtreecommitdiff
path: root/rodion/packages
diff options
context:
space:
mode:
authorRodion Goritskov <rodion.goritskov@gmail.com>2024-05-13 22:22:28 +0400
committerRodion Goritskov <rodion.goritskov@gmail.com>2024-05-13 22:22:28 +0400
commit01b58d81f324daa716f18140f2be1f7ec79bb8d8 (patch)
treed23433e1e228529c11b6a8be2a0c51e6cd314762 /rodion/packages
parentbe613dd7154f163bde2ce53e7d0e3f80a269d79a (diff)
gnu: Add fallout2-ce.
* rodion/packages/fpattern.patch (fallout2-ce): New variable.
Diffstat (limited to 'rodion/packages')
-rw-r--r--rodion/packages/games.scm35
-rw-r--r--rodion/packages/patches/0001-fallout-ce-fpattern.patch (renamed from rodion/packages/fpattern.patch)0
-rw-r--r--rodion/packages/patches/0001-fallout2-ce-fpattern.patch14
3 files changed, 48 insertions, 1 deletions
diff --git a/rodion/packages/games.scm b/rodion/packages/games.scm
index 749806f..e81fe26 100644
--- a/rodion/packages/games.scm
+++ b/rodion/packages/games.scm
@@ -5,6 +5,7 @@
#:use-module (guix git-download)
#:use-module (guix gexp)
#:use-module (gnu packages sdl)
+ #:use-module (gnu packages compression)
#:use-module ((guix licenses) #:prefix license:))
(define-public fpattern
@@ -62,9 +63,41 @@ Filename patterns are composed of regular (printable) characters which may compr
(uri (git-reference
(url "https://github.com/alexbatalov/fallout1-ce")
(commit (string-append "v" version))))
- (patches `(,(local-file "./fpattern.patch")))
+ (patches `(,(local-file "./patches/0001-fallout-ce-fpattern.patch")))
(sha256
(base32 "0c11zbvja42s0z8zqfm6gf981m0v2vwxvhqas46lplwbfhbnh836"))))
(license license:expat)
(description "Fallout")
(synopsis "Fallout")))
+
+(define-public fallout2-ce
+ (package
+ (name "fallout2-ce")
+ (version "1.3.0")
+ (build-system cmake-build-system)
+ (home-page "https://github.com/alexbatalov/fallout2-ce")
+ (inputs (list sdl2
+ fpattern
+ zlib))
+ (arguments
+ (list
+ #:tests? #f
+ #:phases #~(modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (mkdir-p bin)
+ (copy-file "fallout2-ce" (string-append bin "/fallout2-ce"))))))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alexbatalov/fallout2-ce")
+ (commit (string-append "v" version))))
+ (patches `(,(local-file "./patches/0001-fallout2-ce-fpattern.patch")))
+ (sha256
+ (base32 "15b30i2ixq0w01qxrymd1qs1awj8kijbqzac8wvfrpm85fdnfnmg"))))
+ (license license:expat)
+ (description "Fallout")
+ (synopsis "Fallout")))
diff --git a/rodion/packages/fpattern.patch b/rodion/packages/patches/0001-fallout-ce-fpattern.patch
index d2772c5..d2772c5 100644
--- a/rodion/packages/fpattern.patch
+++ b/rodion/packages/patches/0001-fallout-ce-fpattern.patch
diff --git a/rodion/packages/patches/0001-fallout2-ce-fpattern.patch b/rodion/packages/patches/0001-fallout2-ce-fpattern.patch
new file mode 100644
index 0000000..6c58e7e
--- /dev/null
+++ b/rodion/packages/patches/0001-fallout2-ce-fpattern.patch
@@ -0,0 +1,14 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 2de2af1..f6c6ace 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -360,7 +360,8 @@ if(APPLE)
+ set(MACOSX_BUNDLE_BUNDLE_VERSION "1.3.0")
+ endif()
+
+-add_subdirectory("third_party/fpattern")
++find_library(FPATTERN_LIBRARY libfpattern.so)
++find_path(FPATTERN_INCLUDE_DIR fpattern.h)
+ target_link_libraries(${EXECUTABLE_NAME} ${FPATTERN_LIBRARY})
+ target_include_directories(${EXECUTABLE_NAME} PRIVATE ${FPATTERN_INCLUDE_DIR})
+