summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-build.scm8
-rw-r--r--gnu/packages/python-xyz.scm4
2 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index e8cb8d02643..e18fe27fb1d 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -472,18 +472,20 @@ that client code uses to construct the grammar directly in Python code.")
(define-public python-packaging-bootstrap
(package
(name "python-packaging-bootstrap")
- (version "21.3")
+ (version "23.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "packaging" version))
(sha256
(base32
- "1sygirdrqgv4f1ckh9nhpcw1yfidrh3qjl86wq8vk6nq4wlw8iyx"))))
- (build-system python-build-system)
+ "1ifgjb0d0bnnm78hv3mnl7hi233m7jamb2plma752djh83lv13q4"))))
+ (build-system pyproject-build-system)
(arguments `(#:tests? #f)) ;disabled to avoid extra dependencies
(propagated-inputs
(list python-pyparsing python-six-bootstrap))
+ (native-inputs
+ (list python-flit-core))
(home-page "https://github.com/pypa/packaging")
(synopsis "Core utilities for Python packages")
(description "Packaging is a Python module for dealing with Python packages.
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f8fba89a76e..422ba344984 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25219,7 +25219,9 @@ manipulation, or @code{stdout}.")
(if tests?
(invoke "pytest" "-vv")
(format #t "test suite not run~%")))))))
- (native-inputs (list python-pretend python-pytest))
+ (native-inputs
+ (list python-flit-core
+ python-pretend python-pytest))
(propagated-inputs (list python-pyparsing python-six))
(home-page "https://github.com/pypa/packaging")
(synopsis "Core utilities for Python packages")