summaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 292eaef9d07..4a4332c800f 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -924,6 +924,7 @@ and several other projects.")
(define-public python-myst-parser
(package
(name "python-myst-parser")
+ ;; The latest version (v2.0.0) require Sphinx >= v6.
(version "0.18.1")
(source (origin
(method git-fetch) ;for tests
@@ -942,7 +943,17 @@ and several other projects.")
(list #:test-flags #~(list "-k" (string-append
"not test_basic "
"and not test_gettext_html "
- "and not test_fieldlist_extension"))))
+ "and not test_fieldlist_extension "
+ "and not test_syntax_extensions"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "pyproject.toml"
+ ;; "mdit-py-plugins~=0.3.1"
+ (("0.3.1") "0.4.0")
+ ;; "markdown-it-py>=1.0.0,<3.0.0"
+ (("3.0.0") "4.0.0")))))))
(native-inputs
(list python-beautifulsoup4
python-docutils