summaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm24
1 files changed, 16 insertions, 8 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 40633b75c6..ff124717e8 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -110,24 +110,24 @@
texlive-capt-of
texlive-carlisle ;remreset
texlive-etoolbox
- texlive-generic-ltxcmds
+ texlive-ltxcmds
texlive-hyperref
texlive-latex-base ;alltt, atbegshi, makeidx, textcomp
texlive-latex-cmap
- texlive-latex-fancyhdr
- texlive-latex-fancyvrb
+ texlive-fancyhdr
+ texlive-fancyvrb
texlive-latex-float
texlive-latex-fncychap
texlive-latex-framed
texlive-latex-geometry
- texlive-latex-graphics ;graphicx, color
- texlive-latex-kvoptions
+ texlive-graphics ;graphicx, color
+ texlive-kvoptions
texlive-latex-needspace
texlive-latex-parskip
texlive-latex-preview
texlive-latex-tabulary
- texlive-latex-titlesec
- texlive-latex-tools ;multicol, longtable
+ texlive-titlesec
+ texlive-tools ;multicol, longtable
texlive-latex-upquote
texlive-latex-varwidth
texlive-oberdiek ;hypcap
@@ -794,7 +794,15 @@ scientific documentation.")
(base32
"0p3abj91c3l72ajj5jwblscsdf1jflrnn0djx2h5y6f2wjbx9ipf"))))
(build-system python-build-system)
- (arguments '(#:tests? #f)) ; No tests.
+ (arguments
+ (list
+ #:tests? #f ; No tests.
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'allow-newer-docutil
+ (lambda _
+ (substitute* "setup.py"
+ (("docutils<0.18") "docutils<0.20")))))))
(propagated-inputs (list python-docutils python-sphinx))
(home-page "https://github.com/snide/sphinx_rtd_theme/")
(synopsis "ReadTheDocs.org theme for Sphinx")