summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3a7acae776..21845c446d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6521,8 +6521,18 @@ provides Python-specific tags that represent an arbitrary Python object.")
(sha256
(base32 "1q31krwxdvwawdn1kfqmpplix31d4jhs0qng26908hawsf0yjqlb"))))
(build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ ;; AttributeError: 'test_barrier' object has no attribute 'ps'.
+ #~(list "-k" (string-join
+ (list "not test_evaluate"
+ "test_reverse"
+ "test_cancel"
+ "test_throw")
+ " and not "))))
(native-inputs
- (list python-pytest python-case python-setuptools python-wheel))
+ (list python-pytest python-setuptools python-wheel))
(home-page "https://github.com/celery/vine")
(synopsis "Promises for Python")
(description