summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm73
1 files changed, 57 insertions, 16 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 630c4ea97ea..37cabf4cff1 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2019, 2021, 2022, 2023 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2019, 2021-2024 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019, 2020, 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
@@ -528,13 +528,13 @@ Astropy project, but is optimized for use with astropy-related projects.")
(define-public python-pytest-astropy
(package
(name "python-pytest-astropy")
- (version "0.10.0")
+ (version "0.11.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-astropy" version))
(sha256
- (base32 "04g2rh261s3s6ym8mwi4iv2a6anbgwvwzcvkyilfck6yxrncdqw5"))))
+ (base32 "1d9rcxnc57rjp96xag1gq725pwl11b3k5hdaz7c3w5lixncsmbjf"))))
(build-system python-build-system)
(arguments (list #:tests? #f)) ; there are no tests
(native-inputs
@@ -583,16 +583,48 @@ data arrays produced during tests, in particular in cases where the arrays
are too large to conveniently hard-code them in the tests.")
(license license:bsd-3)))
+(define-public python-pytest-cookies
+ (package
+ (name "python-pytest-cookies")
+ (version "0.7.0")
+ (source
+ (origin
+ ;; No tests in the PyPI tarball.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hackebrot/pytest-cookies")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1x7ny6mx1siy9law1cv1i63nvv9ds2g1dlagm40l8qymxry43mjn"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
+ (native-inputs (list python-pytest))
+ (propagated-inputs (list python-cookiecutter))
+ (home-page "https://github.com/hackebrot/pytest-cookies")
+ (synopsis "Pytest plugin for Cookiecutter templates")
+ (description
+ "This Pytest plugin adds a @code{cookies} fixture, which is a
+wrapper for the Cookiecutter API. This fixture helps you verify that
+your template is working as expected and takes care of cleaning up after
+running the tests.")
+ (license license:expat)))
+
(define-public python-pytest-doctestplus
(package
(name "python-pytest-doctestplus")
- (version "0.12.1")
+ (version "1.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-doctestplus" version))
(sha256
- (base32 "10ciqylgziihxwxryxvxgmkqgws51pqcarn0gbh1d4cxx55rx5vs"))))
+ (base32 "17ylfnrcvvp6sd13bfj40jl40paqmjsbywysszb3xqgdr86l8l7n"))))
(build-system pyproject-build-system)
(arguments
(list #:test-flags
@@ -753,13 +785,13 @@ were inadvertently left open at the end of a unit test.")
(define-public python-pytest-remotedata
(package
(name "python-pytest-remotedata")
- (version "0.4.0")
+ (version "0.4.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-remotedata" version))
(sha256
- (base32 "1j5106j331cfdyfcwzrbs3yby84mq1b0kddfysq12z2dwdcca8dy"))))
+ (base32 "0ndvnj9zghfj17haphrygiri9iy38wb8lwq1xdkfvlfd73v8ph05"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -2108,20 +2140,29 @@ help in debugging failures and optimizing the scheduler to improve speed.")
(method url-fetch)
(uri (pypi-uri "pytest-sanic" version))
(sha256
- (base32
- "0shq1bqnydj0l3ipb73j1qh5kqcjvzkps30zk8grq3dwmh3wmnkr"))))
+ (base32
+ "0shq1bqnydj0l3ipb73j1qh5kqcjvzkps30zk8grq3dwmh3wmnkr"))))
+ ;; We don't use pyproject-build-system because that would require
+ ;; poetry.masonry.
(build-system python-build-system)
(arguments
;; Tests depend on python-sanic.
- `(#:tests? #f))
+ (list
+ #:tests? #f
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "setup.py"
+ (("websockets.*<11.0")
+ "websockets<12.0")))))))
(propagated-inputs
- (list python-httpx python-async-generator python-pytest
- python-websockets))
- (home-page
- "https://github.com/yunstanford/pytest-sanic")
+ (list python-httpx python-async-generator python-pytest
+ python-websockets))
+ (home-page "https://github.com/yunstanford/pytest-sanic")
(synopsis "Pytest plugin for Sanic")
- (description "A pytest plugin for Sanic. It helps you to test your
-code asynchronously.")
+ (description "This package provides a pytest plugin for Sanic. It helps
+you to test your code asynchronously.")
(license license:expat)))
(define-public python-allpairspy