summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/screen-hurd-path-max.patch40
1 files changed, 18 insertions, 22 deletions
diff --git a/gnu/packages/patches/screen-hurd-path-max.patch b/gnu/packages/patches/screen-hurd-path-max.patch
index e906f154f3..03b350e79e 100644
--- a/gnu/packages/patches/screen-hurd-path-max.patch
+++ b/gnu/packages/patches/screen-hurd-path-max.patch
@@ -6,14 +6,17 @@ Description: Set PATH_MAX to 4096 if undefined
Fixes FTBFS since 4.4.0 on GNU/Hurd. Updated to add one more occurrence for 4.5.0.
Author: Axel Beckert <abe@debian.org>
Bug: https://savannah.gnu.org/bugs/?50089
-Last-Updated: 2017-01-18
+Updated: 2017-01-18
+Updated: 2024-08-30 Update for Screen 5.0.0
+
+diff --git a/screen.h b/screen.h
+index 308c365..e71bd7f 100644
+--- a/screen.h
++++ b/screen.h
+@@ -63,6 +63,22 @@ struct mode {
+ #endif
+ };
---- a/tty.sh
-+++ b/tty.sh
-@@ -1478,6 +1478,13 @@
- return 0;
- }
-
+/*
+ * Define PATH_MAX to 4096 if it's not defined, like on GNU/Hurd
+ */
@@ -21,22 +24,15 @@ Last-Updated: 2017-01-18
+#ifndef PATH_MAX
+#define PATH_MAX 4096
+#endif
-
- int CheckTtyname (char *tty)
- {
---- a/screen.h
-+++ b/screen.h
-@@ -109,6 +109,13 @@
- # define DEFAULT_BUFFERFILE "/tmp/screen-exchange"
- #endif
-
++
+/*
-+ * Define PATH_MAX to 4096 if it's not defined, like on GNU/Hurd
++ * similarly for MAXPATHLEN
+ */
+
-+#ifndef PATH_MAX
-+#define PATH_MAX 4096
++#ifndef MAXPATHLEN
++#define MAXPATHLEN PATH_MAX
+#endif
-
- #if defined(hpux) && !(defined(VSUSP) && defined(VDSUSP) && defined(VWERASE) && defined(VLNEXT))
- # define HPUX_LTCHARS_HACK
++
+
+ #include "ansi.h"
+ #include "image.h"