summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/maturin-no-cross-compile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/maturin-no-cross-compile.patch')
-rw-r--r--gnu/packages/patches/maturin-no-cross-compile.patch32
1 files changed, 21 insertions, 11 deletions
diff --git a/gnu/packages/patches/maturin-no-cross-compile.patch b/gnu/packages/patches/maturin-no-cross-compile.patch
index 98af33d3c7d..d391d4028c5 100644
--- a/gnu/packages/patches/maturin-no-cross-compile.patch
+++ b/gnu/packages/patches/maturin-no-cross-compile.patch
@@ -2,36 +2,46 @@ Remove dependencies on xwin and zig. We're not offering cross-compilation
options using these crates.
diff --git a/Cargo.toml b/Cargo.toml
-index 6704e46..ff126a9 100644
+index 24305db..c7641f9 100644
--- a/Cargo.toml
+++ b/Cargo.toml
-@@ -83,16 +83,6 @@ version = "0.1.16"
+@@ -95,16 +95,6 @@ version = "0.1.24"
[dependencies.cargo-options]
version = "0.7.2"
-[dependencies.cargo-xwin]
--version = "0.16.2"
+-version = "0.18.3"
-optional = true
-default-features = false
-
-[dependencies.cargo-zigbuild]
--version = "0.18.0"
+-version = "0.19.7"
-optional = true
-default-features = false
-
[dependencies.cargo_metadata]
- version = "0.18.0"
+ version = "0.19.0"
+
+@@ -364,10 +354,6 @@ version = "7.0.0"
-@@ -321,8 +311,6 @@ version = "5.0.0"
[features]
cli-completion = ["dep:clap_complete_command"]
- cross-compile = [
+-cross-compile = [
- "zig",
- "xwin",
- ]
+-]
default = [
"full",
-@@ -341,7 +329,6 @@ log = ["tracing-subscriber"]
+ "rustls",
+@@ -375,7 +361,6 @@ default = [
+ faster-tests = []
+ full = [
+ "cli-completion",
+- "cross-compile",
+ "scaffolding",
+ "upload",
+ ]
+@@ -384,7 +369,6 @@ log = []
native-tls = [
"dep:native-tls",
"ureq?/native-tls",
@@ -39,7 +49,7 @@ index 6704e46..ff126a9 100644
"dep:rustls-pemfile",
]
password-storage = [
-@@ -351,7 +338,6 @@ password-storage = [
+@@ -394,7 +378,6 @@ password-storage = [
rustls = [
"dep:rustls",
"ureq?/tls",
@@ -47,7 +57,7 @@ index 6704e46..ff126a9 100644
"dep:rustls-pemfile",
]
scaffolding = [
-@@ -369,5 +355,3 @@ upload = [
+@@ -416,5 +399,3 @@ upload = [
"wild",
"dep:dirs",
]