summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm23
1 files changed, 6 insertions, 17 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index dd94292f69..e6c13de845 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -3236,24 +3236,13 @@ designed for experienced users.")
(base32
"1xhhy3v4wck74a83avil0rnmsi2grrh03cww19n5mv80p2q1cjmf"))
(modules '((guix build utils)))
- (snippet
- '(begin
- (substitute* "setup.py"
- (("\\=\\=1\\.7") ">=1.7") ; pytest-mock
- (("\\=\\=2\\.5") ">=2.5") ; pytest-cov
- (("4\\.5\\.2") "4.4.2")) ; lxml
- #t))))
- (build-system python-build-system)
+ (snippet '(substitute* "setup.py"
+ (("\\=\\=1\\.7") ">=1.7") ; pytest-mock
+ (("\\=\\=2\\.5") ">=2.5") ; pytest-cov
+ (("4\\.5\\.2") "4.4.2"))))) ; lxml
+ (build-system pyproject-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- ;; Delete failing tests.
- (delete-file "tests/cli/test_run.py")
- (invoke "pytest"))
- #t)))))
+ '(#:test-flags '("--ignore=tests/cli/test_run.py")))
(inputs
(list python-beautifulsoup4
python-lxml