summaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 12d07f53102..23b644ee6e6 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -476,6 +476,31 @@ according to the Desktop Notifications Specification.")
of other programs.")
(license license:lgpl2.1+)))
+(define-public libdbusmenu-lxqt
+ (package
+ (name "libdbusmenu-lxqt")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
+ version "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32 "0knq04si5dzcml35hj29fkp806rrr7gnviqci1diw1k9gxyaf8lc"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ ;; XXX: Tests requires a dbus session and some icons.
+ #:tests? #f))
+ (propagated-inputs
+ (list qtbase))
+ (home-page "https://github.com/lxqt/libdbusmenu-lxqt")
+ (synopsis "Qt implementation of the DBusMenu spec")
+ (description "This library provides a Qt implementation of the DBusMenu
+protocol, forked from @code{libdbusmenu-qt}. The DBusMenu protocol makes it
+possible for applications to export and import their menus over DBus.")
+ (license license:lgpl2.1+)))
+
(define-public lxqt-panel
(package
(name "lxqt-panel")