summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index a9a9e1c945..50decdd14a 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -359,7 +359,9 @@ subdivisions.")
python-numpy
python-pytest
python-scikit-build
- python-setuptools-scm))
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(inputs (list h3))
(home-page "https://uber.github.io/h3-py")
(synopsis "Python bindings for H3")
@@ -1012,7 +1014,7 @@ pyproj, Rtree, and Shapely.")
(list python-fiona python-packaging python-pandas python-pyproj
python-shapely))
(native-inputs
- (list python-pytest))
+ (list python-pytest python-setuptools python-wheel))
(home-page "https://geopandas.org")
(synopsis "Geographic pandas extensions")
(description "The goal of GeoPandas is to make working with
@@ -1141,7 +1143,7 @@ during conversion.")
python-pandas
python-requests
python-shapely))
- (native-inputs (list python-hatchling python-pytest))
+ (native-inputs (list python-hatchling python-pytest python-setuptools python-wheel))
(home-page "https://github.com/gboeing/osmnx")
(synopsis
"Retrieve, model, analyze, and visualize OpenStreetMap street networks")
@@ -2109,7 +2111,7 @@ from multiple records.")
(string-append "\"" libspatialindex
"/lib/libspatialindex_c.so\"")))))))))
(native-inputs
- (list python-numpy python-pytest python-wheel))
+ (list python-numpy python-pytest python-setuptools python-wheel))
(inputs
(list libspatialindex))
(home-page "https://github.com/Toblerity/rtree")