summaryrefslogtreecommitdiff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm18
1 files changed, 16 insertions, 2 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 3962aced33..c6a49a6bc0 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -752,8 +752,22 @@ bcachefs-tools package. It is meant to be used in initrds.")
(base32 "0plj52kjvhy94hdk0bq8bc7ql6yh44x76kryxhn46vwbxayv790j"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags
- (list "--disable-static")))
+ (list
+ #:configure-flags
+ #~(list "--disable-static")
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (setenv "FSCK1" "../fsck/fsck.exfat")
+ ;; Upstream CI uses a second FSCK provided by its host operating
+ ;; system to verify the results of the newly-built one. That
+ ;; makes no sense in Guix, but we can detect crashes, unexpected
+ ;; inconsistencies, and other badness by testing with only one.
+ (setenv "FSCK2" (getenv "FSCK1"))
+ (with-directory-excursion "tests"
+ (invoke "./test_fsck.sh"))))))))
(native-inputs
(list autoconf automake libtool pkg-config))
(home-page "https://github.com/exfatprogs/exfatprogs")