summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 437901b3a8..3ef79b4c26 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -15542,6 +15542,42 @@ browser.")
"http://genome.ucsc.edu/license/"
"The contents of this package are free for all uses."))))
+(define-public skewer
+ (let ((commit "978e8e46cba44595ece623e5387749284a86b74b")
+ (revision "1"))
+ (package
+ (name "skewer")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/relipmoc/skewer")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1b3skfnj3zmd2065fiyxjrg4k6xsxfy6nxz80vmajd830mk6vr69"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda _
+ (install-file "skewer" (string-append #$output "/bin")))))))
+ ;; XXX Fails to build with GCC 11.
+ (native-inputs (list gcc-10))
+ (home-page "https://github.com/relipmoc/skewer")
+ (synopsis "Bit-masked k-difference matching")
+ (description "Skewer implements the bit-masked k-difference matching
+algorithm dedicated to the task of adapter trimming and it is specially
+designed for processing next-generation sequencing (NGS) paired-end
+sequences.")
+ (license license:expat))))
+
(define-public f-seq
(let ((commit "6ccded34cff38cf432deed8503648b4a66953f9b")
(revision "1"))