summaryrefslogtreecommitdiff
path: root/gnu/packages/benchmark.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/benchmark.scm')
-rw-r--r--gnu/packages/benchmark.scm34
1 files changed, 7 insertions, 27 deletions
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index 0cc8def918..733078d875 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -634,39 +634,19 @@ its features are:
;; Do not attempt to invoke the cram command via
;; Python, as on Guix it is a shell script (wrapper).
(("\\$\\(command -v cram\\)")
- "-m cram"))))
+ "-m cram"))
+ (substitute* "tests/t/opt_report_checkpoints.t"
+ ;; egrep outputs a deprecation warning, which breaks
+ ;; the test.
+ (("egrep")
+ "grep -E"))))
(add-after 'unpack 'disable-test-installation
(lambda _
(substitute* "tests/Makefile.am"
(("install-data-local")
"do-not-install-data-local")
(("^test_SCRIPTS.*")
- ""))))
- (add-after 'unpack 'fix-docbook
- (lambda* (#:key native-inputs inputs #:allow-other-keys)
- (substitute* "m4/ax_check_docbook.m4"
- (("DOCBOOK_ROOT=.*" all)
- (string-append
- all "XML_CATALOG="
- (search-input-file (or native-inputs inputs)
- "xml/dtd/docbook/catalog.xml")
- "\n")))
- (substitute* "doc/xsl/xhtml.xsl"
- (("http://docbook.sourceforge.net/release/xsl\
-/current/xhtml/docbook.xsl")
- (search-input-file
- (or native-inputs inputs)
- (string-append "xml/xsl/docbook-xsl-"
- #$(package-version docbook-xsl)
- "/xhtml/docbook.xsl"))))
- (substitute* "doc/xsl/xhtml-chunk.xsl"
- (("http://docbook.sourceforge.net/release/xsl\
-/current/xhtml/chunk.xsl")
- (search-input-file
- (or native-inputs inputs)
- (string-append "xml/xsl/docbook-xsl-"
- #$(package-version docbook-xsl)
- "/xhtml/chunk.xsl")))))))))
+ "")))))))
(native-inputs (list autoconf
automake
libtool