summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm28
1 files changed, 2 insertions, 26 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 9aa6c0e385..c5e5ae9330 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -4924,43 +4924,19 @@ over many parameters:
(define-public python-statmorph
(package
(name "python-statmorph")
- (version "0.5.7")
+ (version "0.6.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "statmorph" version))
(sha256
- (base32 "06rbwrqlvdzn9innx05kjjmm4mmacd8kwwsfdf5idbwzby5ny5lw"))))
+ (base32 "1575vmk4kl06yxyid7mb1r7llbrmraagvx2b0h5x335ha7irnkjk"))))
(build-system pyproject-build-system)
- (arguments
- (list
- #:test-flags
- ;; XXX: Skip most of the tests for now, see
- ;; <https://github.com/vrodgom/statmorph/issues/11>.
- #~(list "-k" (string-append "not test_asymmetric"
- " and not test_bright_pixel"
- " and not test_catastrophic"
- " and not test_empty_gini_segmap"
- " and not test_full_gini_segmap"
- " and not test_full_segmap"
- " and not test_insufficient_data"
- " and not test_make_figure"
- " and not test_masked_centroid"
- " and not test_merger"
- " and not test_missing_arguments"
- " and not test_negative_source"
- " and not test_no_psf"
- " and not test_psf"
- " and not test_random_noise"
- " and not test_small_source"
- " and not test_tiny_source"
- " and not test_weightmap"))))
(native-inputs
(list python-pytest
python-setuptools))
(propagated-inputs
(list python-astropy
- python-matplotlib
python-numpy
python-photutils
python-scikit-image