summaryrefslogtreecommitdiff
path: root/gnu/packages/aspell.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/aspell.scm')
-rw-r--r--gnu/packages/aspell.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/aspell.scm b/gnu/packages/aspell.scm
index ef225ac64d4..ec0dafbc7a5 100644
--- a/gnu/packages/aspell.scm
+++ b/gnu/packages/aspell.scm
@@ -47,6 +47,7 @@
(package
(name "aspell")
(version "0.60.8")
+ (replacement aspell/replacement)
(source
(origin
(method url-fetch)
@@ -92,6 +93,16 @@ documents written in the UTF-8 encoding and its ability to use multiple
dictionaries, including personal ones.")
(license lgpl2.1+)))
+;; Replacement package with security fixes.
+(define aspell/replacement
+ (package
+ (inherit aspell)
+ (source
+ (origin
+ (inherit (package-source aspell))
+ (patches (append (origin-patches (package-source aspell))
+ (search-patches "aspell-CVE-2019-25051.patch")))))))
+
;;;
;;; Dictionaries.
;;;