summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 4d7b4001cd..32834f1c15 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -245,16 +245,15 @@ the real span of the lattice.")
(native-inputs (list (texlive-updmap.cfg)))
(inputs (list gmp libx11 perl readline))
(arguments
- '(#:make-flags '("all")
- #:test-target "dobench"
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "./Configure"
- "--mt=pthread"
- (string-append "--prefix="
- (assoc-ref outputs "out"))))))))
+ (list
+ #:test-target "dobench"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (invoke "./Configure"
+ "--mt=pthread"
+ (string-append "--prefix=" #$output)))))))
(synopsis "PARI/GP, a computer algebra system for number theory")
(description
"PARI/GP is a widely used computer algebra system designed for fast