summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-check.scm2
-rw-r--r--gnu/packages/python-science.scm2
-rw-r--r--gnu/packages/python-xyz.scm20
3 files changed, 2 insertions, 22 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 6b577175f7..1cb077ce86 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -412,7 +412,7 @@ nosetests, etc...) in Python projects.")
python-mypy
python-numpy
python-setuptools
- python-typeguard-4))
+ python-typeguard))
(propagated-inputs
(list python-asttokens
python-typing-extensions))
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index b188f113ae..42a64aed6e 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1410,7 +1410,7 @@ idea of the remaining amount of computation to be done.")
python-pandas-stubs ;mypy extra
python-pydantic
python-scipy ;hypotheses extra
- python-typeguard-4
+ python-typeguard
python-typing-inspect
python-wrapt))
(native-inputs (list python-dask ;dask extra
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1410f65d29..78f924af88 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27548,26 +27548,6 @@ based on the CPython 2.7 and 3.7 parsers.")
with PEP 484 argument (and return) type annotations.")
(license license:expat)))
-(define-public python-typeguard-4
- (package
- (inherit python-typeguard)
- (name "python-typeguard")
- ;; This is the latest version we can use, because python-typeguard >=
- ;; 4.0.1 requires python-typing-extensions >= 4.7.0.
- (version "4.0.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "typeguard" version))
- (sha256
- (base32 "11yrc7pv2fajmicwiyc92sb5gphlw3zbxww8f2prrsh6rgdv6kqr"))))
- (build-system pyproject-build-system)
- (arguments
- (list #:test-flags '(list "--ignore=tests/mypy")))
- (propagated-inputs (list python-typing-extensions))
- (native-inputs (modify-inputs (package-native-inputs python-typeguard)
- (append python-setuptools python-wheel)))))
-
(define-public bpython
(package
(name "bpython")