summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/fontutils.scm6
-rw-r--r--gnu/packages/python-xyz.scm4
2 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 03f4e05b562..edd29479cec 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -148,6 +148,12 @@ them as it goes.")
(modules '((guix build utils)))
(snippet
#~(begin
+ (substitute*
+ "tests/buildcff2vf_data/expected_output/SHSansJPVFTest.ttx"
+ ;; Adjust expected output to match newer fonttools. Taken from:
+ ;; https://github.com/adobe-type-tools/afdko/commit/7c526390a10e
+ (("FDSelect format=\"3\"")
+ "FDSelect format=\"0\""))
(with-directory-excursion "c/makeotf/lib/hotconv"
;; Delete ANTLR-generated code.
(for-each delete-file
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c140044dfcd..ff9f4581676 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11407,14 +11407,14 @@ from an XML-based format.")
(define-public python-fonttools-next
(package
(inherit python-fonttools-full)
- (version "4.32.0")
+ (version "4.37.1")
(source (origin
(inherit (package-source python-fonttools-full))
(method url-fetch)
(uri (pypi-uri "fonttools" version ".zip"))
(sha256
(base32
- "14nk43z0dmznypm3zp4sdc04x1y608jawlnmwdkk32a947khvaar"))))))
+ "1ryc1wca2v92wn24baryj5fr32lspl8rbsig32fnkxp1islf21j6"))))))
(define-public python-ly
(package