summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/freedesktop.scm25
-rw-r--r--gnu/packages/patches/xdg-desktop-portal-disable-portal-tests.patch56
3 files changed, 10 insertions, 72 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 979e6bad74..5cdf88d756 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -2308,7 +2308,6 @@ dist_patch_DATA = \
%D%/packages/patches/wordnet-CVE-2008-3908-pt2.patch \
%D%/packages/patches/wpa-supplicant-dbus-group-policy.patch \
%D%/packages/patches/x265-arm-flags.patch \
- %D%/packages/patches/xdg-desktop-portal-disable-portal-tests.patch\
%D%/packages/patches/xdg-desktop-portal-wlr-harcoded-length.patch\
%D%/packages/patches/xen-docs-use-predictable-ordering.patch \
%D%/packages/patches/xen-remove-config.gz-timestamp.patch \
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 289c4ea281..2a78895a20 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -39,7 +39,6 @@
;;; Copyright © 2024 aurtzy <aurtzy@gmail.com>
;;; Copyright © 2024 Dariqq <dariqq@posteo.net>
;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
-;;; Copyright © 2024 dan <i@dan.games>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -137,7 +136,6 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages valgrind)
#:use-module (gnu packages video)
- #:use-module (gnu packages virtualization)
#:use-module (gnu packages w3m)
#:use-module (gnu packages web)
#:use-module (gnu packages xdisorg)
@@ -3012,7 +3010,7 @@ compatible with the well-known scripts of the same name.")
(define-public xdg-desktop-portal
(package
(name "xdg-desktop-portal")
- (version "1.18.4")
+ (version "1.16.0")
(source
(origin
(method url-fetch)
@@ -3021,21 +3019,18 @@ compatible with the well-known scripts of the same name.")
version "/xdg-desktop-portal-" version ".tar.xz"))
(sha256
(base32
- "0r8y8qmzcfj7b7brqcxr9lg8pavfds815ffvj0kqc378fhgaln5q"))
- ;; Disable portal tests since they try to use fuse.
- (patches (search-patches "xdg-desktop-portal-disable-portal-tests.patch"))))
- (build-system meson-build-system)
+ "06cczlh39kc41rvav06v37sad827y61rffy3v29i918ibj8sahav"))))
+ (build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
("glib:bin" ,glib "bin")
- ("gettext" ,gettext-minimal)
- ("python" ,python)
- ("python-dbusmock" ,python-dbusmock)
- ("python-pytest" ,python-pytest)
- ("python-pytest-xdist" ,python-pytest-xdist)))
+ ("which" ,which)
+ ("gettext" ,gettext-minimal)))
(inputs
- `(("bubblewrap" ,bubblewrap)
- ("gdk-pixbuf" ,gdk-pixbuf)
+ `(("gdk-pixbuf" ,gdk-pixbuf)
("glib" ,glib)
("flatpak" ,flatpak)
("fontconfig" ,fontconfig)
@@ -3047,7 +3042,7 @@ compatible with the well-known scripts of the same name.")
("fuse" ,fuse)))
(arguments
`(#:configure-flags
- (list "-Dsystemd=disabled")
+ (list "--with-systemd=no")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'po-chmod
diff --git a/gnu/packages/patches/xdg-desktop-portal-disable-portal-tests.patch b/gnu/packages/patches/xdg-desktop-portal-disable-portal-tests.patch
deleted file mode 100644
index 5e13493613..0000000000
--- a/gnu/packages/patches/xdg-desktop-portal-disable-portal-tests.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From b7750fa99c31c5f28ac2053fa154bef4038b5cc0 Mon Sep 17 00:00:00 2001
-From: dan <i@dan.games>
-Date: Tue, 2 Jul 2024 19:37:38 +0800
-Subject: [PATCH] tests: remove portal tests.
-
----
- tests/meson.build | 24 ------------------------
- 1 file changed, 24 deletions(-)
-
-diff --git a/tests/meson.build b/tests/meson.build
-index a2dafee..bcd87be 100644
---- a/tests/meson.build
-+++ b/tests/meson.build
-@@ -181,18 +181,6 @@ portal_tests = [
-
- test_env = env_tests
- test_env.set('XDG_CURRENT_DESKTOP', 'test')
--foreach p : portal_tests
-- test(
-- 'test-portals-@0@'.format(p),
-- test_portals,
-- args: ['--verbose', '--keep-going', '--tap', '-p', '/portal/@0@'.format(p)],
-- depends: [test_backends, test_portals],
-- env: test_env,
-- is_parallel: false,
-- protocol: test_protocol,
-- suite: 'portals',
-- )
--endforeach
-
- # Split the portal tests into one test per portal, this makes debugging a lot
- # easier.
-@@ -204,18 +192,6 @@ portal_limited = [
-
- limited_env = env_tests
- limited_env.set('XDG_CURRENT_DESKTOP', 'limited')
--foreach p : portal_limited
-- test(
-- 'limited-portals-@0@'.format(p),
-- limited_portals,
-- args: ['--verbose', '--keep-going', '--tap', '-p', '/limited/@0@'.format(p)],
-- depends: [test_backends, limited_portals],
-- env: limited_env,
-- is_parallel: false,
-- protocol: test_protocol,
-- suite: 'portals',
-- )
--endforeach
-
- if enable_installed_tests
- install_data(
-
-base-commit: 11c8a96b147aeae70e3f770313f93b367d53fedd
---
-2.41.0
-