summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-12-30 10:48:41 +0100
committerLudovic Courtès <ludo@gnu.org>2024-12-30 11:01:54 +0100
commitbdde278dc9c565d8e9d11427c3a670ba86808af5 (patch)
treed59eeb2013f35a3eb1e3fb8fd83114657d37cdd7 /tests
parent4ebc1aba19d75af1b22f269f042a51513205f20c (diff)
import: pypi: Adjust test to new setuptools and wheel requirements.
This is a followup to c904350a81f9ff47cc025bc9d0d48f1bd2ead30e and d7890af335ed046ba245137fb13031be964d03f5, which led to adding ‘setuptools’ and ‘wheel’ to ‘native-inputs’ in many (most?) cases. * tests/pypi.scm ("pypi->guix-package, no wheel") ("pypi->guix-package, no requires.txt, but wheel.") ("pypi->guix-package, no usable requirement file, no wheel."): Add ‘python-setuptools’ and ‘python-wheel’ to the native inputs. ("package-latest-release"): Add ‘setuptools’ and ‘wheel’ to the expected result. Change-Id: I4d1001b0ad332836fe7d1d9ecd07d4adc32330af
Diffstat (limited to 'tests')
-rw-r--r--tests/pypi.scm21
1 files changed, 18 insertions, 3 deletions
diff --git a/tests/pypi.scm b/tests/pypi.scm
index fe00e429b7..3fbce1786f 100644
--- a/tests/pypi.scm
+++ b/tests/pypi.scm
@@ -326,7 +326,9 @@ files specified by SPECS. Return its file name."
(base32 ,(? string? hash)))))
(build-system pyproject-build-system)
(propagated-inputs (list python-bar python-foo))
- (native-inputs (list python-pytest))
+ (native-inputs (list python-pytest
+ python-setuptools
+ python-wheel))
(home-page "http://example.com")
(synopsis "summary")
(description "summary.")
@@ -444,7 +446,9 @@ files specified by SPECS. Return its file name."
(base32 ,(? string? hash)))))
(build-system pyproject-build-system)
(propagated-inputs (list python-bar python-baz))
- (native-inputs (list python-pytest))
+ (native-inputs (list python-pytest
+ python-setuptools
+ python-wheel))
(home-page "http://example.com")
(synopsis "summary")
(description "summary.")
@@ -473,6 +477,7 @@ files specified by SPECS. Return its file name."
(sha256
(base32 ,(? string? hash)))))
(build-system pyproject-build-system)
+ (native-inputs (list python-setuptools python-wheel))
(home-page "http://example.com")
(synopsis "summary")
(description "summary.")
@@ -502,7 +507,9 @@ files specified by SPECS. Return its file name."
(properties (quote (("upstream-name" . "foo-99"))))
(build-system pyproject-build-system)
(propagated-inputs (list python-bar python-foo))
- (native-inputs (list python-pytest))
+ (native-inputs (list python-pytest
+ python-setuptools
+ python-wheel))
(home-page "http://example.com")
(synopsis "summary")
(description "summary.")
@@ -525,6 +532,14 @@ files specified by SPECS. Return its file name."
(upstream-input
(name "pytest")
(downstream-name "python-pytest")
+ (type 'native))
+ (upstream-input
+ (name "setuptools")
+ (downstream-name "python-setuptools")
+ (type 'native))
+ (upstream-input
+ (name "wheel")
+ (downstream-name "python-wheel")
(type 'native))))
(let ((tarball (pypi-tarball
"foo-1.0.0"