summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-07 17:01:27 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:37 +0000
commite3222a53022b01fbba12708133f3b8bcb4dacf52 (patch)
tree71745276788b74f81e0bf8d0415d066d615e4c24 /gnu
parentdfc6e1b0d0affa96444d974d1cb567ed8e02772f (diff)
gnu: Add python-referencing.
* gnu/packages/python-xyz.scm (python-referencing, python-referencing-bootstrap): New variables. Change-Id: I16b9d32644204a72c46a2d51ebf3771d90cd099a
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 22a4d13843..637faed3b3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -34087,6 +34087,57 @@ YAML. It takes care of defaults, overrides, type checking, command-line
integration, human-readable errors, and standard OS-specific locations.")
(license license:expat)))
+(define-public python-referencing
+ (package
+ (name "python-referencing")
+ (version "0.35.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "referencing" version))
+ (sha256
+ (base32 "0g3hvzz6ci6dcf701q7ilr4b7vw3fw428kqp4nj35dn8lqj23d15"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ '(list "--pyargs" "referencing/tests")
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'patch-pyproject
+ (lambda _
+ ;; The build system does not like this.
+ (substitute* "pyproject.toml"
+ ((" \"Topic :: File Formats.*") "")))))))
+ (propagated-inputs (list python-attrs python-rpds-py))
+ (native-inputs
+ (list python-hatchling
+ python-hatch-vcs
+ python-jsonschema
+ python-pytest
+ python-pytest-subtests))
+ (home-page "https://github.com/python-jsonschema/referencing")
+ (synopsis "JSON Referencing + Python")
+ (description "This package provides an implementation-agnostic
+implementation of JSON reference resolution.")
+ (license license:expat)))
+
+(define-public python-referencing-bootstrap
+ (package
+ (inherit python-referencing)
+ (name "python-referencing-bootstrap")
+ (arguments
+ (list
+ #:tests? #false
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'patch-pyproject
+ (lambda _
+ ;; The build system does not like this.
+ (substitute* "pyproject.toml"
+ ((" \"Topic :: File Formats.*") "")))))))
+ (native-inputs (list python-hatchling python-hatch-vcs))))
+
(define-public python-reflink
(package
(name "python-reflink")