summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-06 22:42:53 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:37 +0000
commitdfc6e1b0d0affa96444d974d1cb567ed8e02772f (patch)
treed0e087e810462d7e4c43c5d175b3fbe2ecb6fd4f /gnu
parentd3c25e263ccb0c04bc70139d2b1756aa9e34843d (diff)
gnu: Add python-pep440.
* gnu/packages/python-xyz.scm (python-pep440): New variable. Change-Id: I307eb0d50e5e6378fb840b775964761833cb9488
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e1ccf1a6b4..22a4d13843 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14847,6 +14847,31 @@ PEP 8.")
plugin for flake8 to check PEP-8 naming conventions.")
(license license:expat)))
+(define-public python-pep440
+ (package
+ (name "python-pep440")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pep440" version))
+ (sha256
+ (base32 "0kfhysbyci4f2sxvv991yvn22kbhncn0jg1arbhzw4rbri375csq"))))
+ (build-system pyproject-build-system)
+ (arguments
+ ;; This checks for "pep440" in the output, but we actually print
+ ;; ".pep440-real" due to wrapping.
+ (list #:test-flags '(list "-k" "not test_cli_help")))
+ (propagated-inputs (list python-check-manifest python-mypy python-pytest
+ python-pytest-console-scripts python-pytest-cov))
+ (native-inputs (list python-flit-core))
+ (home-page "https://pypi.org/project/pep440/")
+ (synopsis "Utils to check whether versions number match PEP 440")
+ (description
+ "This package provides a simple package with utils to check whether
+versions number match PEP 440.")
+ (license license:expat)))
+
(define-public python-pep517
(package
(inherit python-pep517-bootstrap)