summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2024-02-13 14:15:38 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:30 +0000
commitccb2541641a16d964a4ad620a5898a145e5da443 (patch)
tree5fd05803e5924db136db923dc55704403a3f2f71 /gnu
parent976cb712f581495194449e4c5f4627c2b8e5e6ba (diff)
gnu: python-markdown-it-py: Update to 3.0.0.
* gnu/packages/python-xyz.scm (python-markdown-it-py): Update to 3.0.0. [propagated-inputs]: Remove python-typing-extensions; add python-commonmark, python-linkify-it-py, python-markdown, python-mistletoe, python-mistune, python-panflute, python-psutil, and python-pyyaml. [native-inputs]: Remove python-flit; add python-flit-core. Change-Id: I5dc06b163ddbec0a32a9d7c3da2c834b2e74cd74 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 12 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8574dfae11..c1585e131e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6461,19 +6461,26 @@ given signature. It was largely inspired by @code{python-decorator} and
(define-public python-markdown-it-py
(package
(name "python-markdown-it-py")
- (version "2.1.0")
+ (version "3.0.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "markdown-it-py" version))
(sha256
(base32
- "1nh75i72584r70alhqc479gys04s5m5g3vq601yf2njbs7z5jzng"))))
+ "1swgvyiavak0nmfb31lq5zck5chwhmyf6qb6qwpcav86zaa0mxp3"))))
(build-system pyproject-build-system)
(arguments (list #:tests? #f)) ;pypi source does not contains tests
- (native-inputs (list python-flit))
+ (native-inputs (list python-flit-core))
(propagated-inputs
- (list python-mdurl
- python-typing-extensions))
+ (list python-commonmark
+ python-linkify-it-py
+ python-markdown
+ python-mdurl
+ python-mistletoe
+ python-mistune
+ python-panflute
+ python-psutil
+ python-pyyaml))
(home-page "https://github.com/executablebooks/markdown-it-py")
(synopsis "Python port of markdown-it")
(description