summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2024-11-20 08:35:47 +0800
committerHilton Chain <hako@ultrarare.space>2024-12-31 18:50:45 +0800
commitc66584933f4c9051eb4c10deae96cf25c65198ab (patch)
treefed3866f448fed2f66662f14405bfaa25c0f2944 /gnu
parent23020cf115a906305ae6afd399c828153170ebfd (diff)
gnu: Add zig-wayland.
* gnu/packages/zig-xyz.scm (zig-wayland): New variable. Change-Id: Ibb060d6b684e139e42297050223aa3f9110ae118
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/zig-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index af4c3d2f4c..09587aec46 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -129,6 +129,36 @@ mission-critical safety and performance for financial services.")
(home-page "https://codeberg.org/ifreund/zig-pixman")
(license license:expat)))
+(define-public zig-wayland
+ (package
+ (name "zig-wayland")
+ (version "0.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/ifreund/zig-wayland")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1cf5085f6c0yly4fcr49jry3mh12bybw98x5lvickl6w5gxsvy3n"))))
+ (build-system zig-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'configure 'fix-cross-compilation
+ (lambda _
+ (substitute* "build.zig"
+ (("pkg-config") (getenv "PKG_CONFIG"))))))))
+ (propagated-inputs (list wayland wayland-protocols))
+ (native-inputs (list pkg-config wayland))
+ (synopsis "Zig Wayland bindings and protocol scanner")
+ (description
+ "This package provides Zig bindings for @code{wayland} and a @code{Scanner}
+interface.")
+ (home-page "https://codeberg.org/ifreund/zig-wayland")
+ (license license:expat)))
+
(define-public zig-zls
(package
(name "zig-zls")