summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-08-14 14:30:13 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-08-14 14:31:59 +0200
commitc0e782f0dad914109f04f2554b9842ff1f51ee1b (patch)
tree16956a04c74b340c6ee87bf81244f666f7e4a7a3 /gnu
parent8bd68bd2209cb4e5fa43208730d29bd7cd15c184 (diff)
gnu: linux-libre: Add perf probe support.
* gnu/packages/aux-files/linux-libre/5.10-i686.conf: Enable CONFIG_UPROBE_EVENTS option. * gnu/packages/aux-files/linux-libre/5.10-x86_64.conf: Ditto. * gnu/packages/aux-files/linux-libre/5.13-i686.conf: Ditto. * gnu/packages/aux-files/linux-libre/5.13-x86_64.conf: Ditto. * gnu/packages/aux-files/linux-libre/5.4-i686.conf: Ditto. * gnu/packages/aux-files/linux-libre/5.4-x86_64.conf: Ditto.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/aux-files/linux-libre/5.10-i686.conf2
-rw-r--r--gnu/packages/aux-files/linux-libre/5.10-x86_64.conf2
-rw-r--r--gnu/packages/aux-files/linux-libre/5.13-i686.conf2
-rw-r--r--gnu/packages/aux-files/linux-libre/5.13-x86_64.conf2
-rw-r--r--gnu/packages/aux-files/linux-libre/5.4-i686.conf2
-rw-r--r--gnu/packages/aux-files/linux-libre/5.4-x86_64.conf2
6 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/aux-files/linux-libre/5.10-i686.conf b/gnu/packages/aux-files/linux-libre/5.10-i686.conf
index e400c42362f..cb1fdc37ad7 100644
--- a/gnu/packages/aux-files/linux-libre/5.10-i686.conf
+++ b/gnu/packages/aux-files/linux-libre/5.10-i686.conf
@@ -10612,7 +10612,7 @@ CONFIG_BRANCH_PROFILE_NONE=y
CONFIG_BLK_DEV_IO_TRACE=y
CONFIG_KPROBE_EVENTS=y
# CONFIG_KPROBE_EVENTS_ON_NOTRACE is not set
-# CONFIG_UPROBE_EVENTS is not set
+CONFIG_UPROBE_EVENTS=y
CONFIG_BPF_EVENTS=y
CONFIG_DYNAMIC_EVENTS=y
CONFIG_PROBE_EVENTS=y
diff --git a/gnu/packages/aux-files/linux-libre/5.10-x86_64.conf b/gnu/packages/aux-files/linux-libre/5.10-x86_64.conf
index bf4451c9940..cd61860af95 100644
--- a/gnu/packages/aux-files/linux-libre/5.10-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/5.10-x86_64.conf
@@ -10620,7 +10620,7 @@ CONFIG_BRANCH_PROFILE_NONE=y
CONFIG_BLK_DEV_IO_TRACE=y
CONFIG_KPROBE_EVENTS=y
# CONFIG_KPROBE_EVENTS_ON_NOTRACE is not set
-# CONFIG_UPROBE_EVENTS is not set
+CONFIG_UPROBE_EVENTS=y
CONFIG_BPF_EVENTS=y
CONFIG_DYNAMIC_EVENTS=y
CONFIG_PROBE_EVENTS=y
diff --git a/gnu/packages/aux-files/linux-libre/5.13-i686.conf b/gnu/packages/aux-files/linux-libre/5.13-i686.conf
index d1231177163..209c5974647 100644
--- a/gnu/packages/aux-files/linux-libre/5.13-i686.conf
+++ b/gnu/packages/aux-files/linux-libre/5.13-i686.conf
@@ -10765,7 +10765,7 @@ CONFIG_BRANCH_PROFILE_NONE=y
CONFIG_BLK_DEV_IO_TRACE=y
CONFIG_KPROBE_EVENTS=y
# CONFIG_KPROBE_EVENTS_ON_NOTRACE is not set
-# CONFIG_UPROBE_EVENTS is not set
+CONFIG_UPROBE_EVENTS=y
CONFIG_BPF_EVENTS=y
CONFIG_DYNAMIC_EVENTS=y
CONFIG_PROBE_EVENTS=y
diff --git a/gnu/packages/aux-files/linux-libre/5.13-x86_64.conf b/gnu/packages/aux-files/linux-libre/5.13-x86_64.conf
index e268705a714..b07a37a85d1 100644
--- a/gnu/packages/aux-files/linux-libre/5.13-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/5.13-x86_64.conf
@@ -10831,7 +10831,7 @@ CONFIG_BRANCH_PROFILE_NONE=y
CONFIG_BLK_DEV_IO_TRACE=y
CONFIG_KPROBE_EVENTS=y
# CONFIG_KPROBE_EVENTS_ON_NOTRACE is not set
-# CONFIG_UPROBE_EVENTS is not set
+CONFIG_UPROBE_EVENTS=y
CONFIG_BPF_EVENTS=y
CONFIG_DYNAMIC_EVENTS=y
CONFIG_PROBE_EVENTS=y
diff --git a/gnu/packages/aux-files/linux-libre/5.4-i686.conf b/gnu/packages/aux-files/linux-libre/5.4-i686.conf
index 898c66ebf92..4e2d7795c71 100644
--- a/gnu/packages/aux-files/linux-libre/5.4-i686.conf
+++ b/gnu/packages/aux-files/linux-libre/5.4-i686.conf
@@ -10214,7 +10214,7 @@ CONFIG_STACK_TRACER=y
CONFIG_BLK_DEV_IO_TRACE=y
CONFIG_KPROBE_EVENTS=y
# CONFIG_KPROBE_EVENTS_ON_NOTRACE is not set
-# CONFIG_UPROBE_EVENTS is not set
+CONFIG_UPROBE_EVENTS=y
CONFIG_BPF_EVENTS=y
CONFIG_DYNAMIC_EVENTS=y
CONFIG_PROBE_EVENTS=y
diff --git a/gnu/packages/aux-files/linux-libre/5.4-x86_64.conf b/gnu/packages/aux-files/linux-libre/5.4-x86_64.conf
index 19fdeb7e702..5815caa7707 100644
--- a/gnu/packages/aux-files/linux-libre/5.4-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/5.4-x86_64.conf
@@ -10164,7 +10164,7 @@ CONFIG_STACK_TRACER=y
CONFIG_BLK_DEV_IO_TRACE=y
CONFIG_KPROBE_EVENTS=y
# CONFIG_KPROBE_EVENTS_ON_NOTRACE is not set
-# CONFIG_UPROBE_EVENTS is not set
+CONFIG_UPROBE_EVENTS=y
CONFIG_BPF_EVENTS=y
CONFIG_DYNAMIC_EVENTS=y
CONFIG_PROBE_EVENTS=y