summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 10:46:41 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:25 +0200
commitbac73b47bd97c4d07cc09087d41cff6b3a0b002b (patch)
treeef45c927cf73dacfdf472493470510345a423cb2 /gnu
parent9aeddf892a4133d9cf6d9d8baccc1e0186ce08af (diff)
gnu: Add texlive-docbytex.
* gnu/packages/tex.scm (texlive-docbytex): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 45af13ce50..3d590d2f57 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1539,6 +1539,27 @@ displaying one step in to the right. The macros work equally well with Plain
TeX and with LaTeX.")
(license license:lppl)))
+(define-public texlive-docbytex
+ (package
+ (name "texlive-docbytex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/docbytex/"
+ "tex/generic/docbytex/")
+ (base32
+ "09x4xpyq89jjjsp4yzrifcazz0p2f5w7785g8pvss8v0wwsb0lav")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/docbytex")
+ (synopsis "Creating documentation from source code")
+ (description
+ "The package creates documentation from C source code, or other
+programming languages.")
+ ;; README states: "You can do anything with the files from DocBy.TeX
+ ;; package without any limit".
+ (license (license:fsf-free "file://doc/generic/docbytex/README"))))
+
(define-public texlive-dosepsbin
(package
(name "texlive-dosepsbin")