summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2024-02-13 14:15:41 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:31 +0000
commit98cab4b183062f4c5e036efaa6c602db4aa311e0 (patch)
treed398d1e1bce54752cf5bfa4247bc5351c8d55734 /gnu
parent8ba5d79d5af05ef0abcd471f601096f32062a4a3 (diff)
gnu: python-rich: Update to 13.7.0.
* gnu/packages/python-xyz.scm (python-rich): Update to 13.7.0. [source]: Use git-fetch since pypi package doesn't include tests. [build-system]: Use pyproject-build-system. [arguments]: Remove custom 'check phase. [propagated-inputs]: Remove python-attrs, python-colorama, python-commonmark and python-typingextensions; add python-ipywidgets and python-markdown-it-py. [native-inputs]: Add python-poetry-core; remove tests (which are now included in new [source]). Change-Id: I15f7928fc376d8c2556ca2965fe44453bd15f248 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm49
1 files changed, 15 insertions, 34 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d462b18769..b444f59a78 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20665,42 +20665,23 @@ representation.")
(define-public python-rich
(package
(name "python-rich")
- (version "12.4.1")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "rich" version))
- (sha256
- (base32
- "149vjb4cpf9mz14iig0b6d8065dm8aslp6pc45g9ipmp1wf00ffj"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs tests? #:allow-other-keys)
- (when tests?
- (copy-recursively (string-append
- (assoc-ref inputs "tests") "/tests")
- "tests")
- (invoke "python" "-m" "pytest" "-vv")))))))
+ (version "13.7.0")
+ (source
+ (origin
+ ;; There are no tests in the PyPI tarball.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/willmcgugan/rich")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qyhw2vvk17qdmfrmi45z4dd0fkwx3l2qrf3iy0yc2y7pfgrmg9g"))))
+ (build-system pyproject-build-system)
(propagated-inputs
- (list python-attrs python-colorama python-commonmark python-pygments
- python-typing-extensions))
+ (list python-ipywidgets python-markdown-it-py python-pygments))
(native-inputs
- `(("python-pytest" ,python-pytest)
- ("tests"
- ;; The release on pypi comes without tests. We can't build from this
- ;; checkout, though, because installation requires an invocation of
- ;; poetry.
- ,(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/willmcgugan/rich")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "17c3gljn8zv32xnpsgd3fqgqn4r7cdfqri41hridcpbhssdgkyp9"))))))
+ (list python-poetry-core python-pytest))
(home-page "https://github.com/willmcgugan/rich")
(synopsis "Render rich text and more to the terminal")
(description