summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2024-04-29 21:40:48 +0100
committerLudovic Courtès <ludo@gnu.org>2024-12-22 22:56:01 +0100
commit988ceea7438e459c738224797ec047559ef827b7 (patch)
treed35518bb990b09e28affef2ec40bb7bfce0cb5e2 /gnu
parent976ea30c467f3d46821d77fb9f5f1535d3b62254 (diff)
gnu: python-pbr: Use git-minimal/pinned.
This helps reduce the dependencies on git, as I think it's find to build with a slightly older git, at least during periods when git-minimal/pinned needs updating. * gnu/packages/version-control.scm (python-pbr)[propagated-inputs]: Use git-minimal/pinned. Change-Id: Ib90056a1a603e06a99b5c601f9fcba7375dc24ac Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7cf44d6b6b..fe2b4b6d56 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5696,7 +5696,7 @@ code introspection, and logging.")
(arguments
`(#:tests? #f)) ;; Most tests seem to use the Internet.
(propagated-inputs
- (list git)) ;; pbr actually uses the "git" binary.
+ (list git-minimal/pinned)) ;; pbr actually uses the "git" binary.
(native-inputs
`(("python-fixtures" ,python-fixtures-bootstrap)
;; discover, coverage, hacking, subunit