summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-02-27 15:56:13 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:31 +0000
commit92581c8a2e2d7a3e78af96aa99005f86d1a3a750 (patch)
treedee360c2fbcc88590be1d90b59c51486cd3fd54f /gnu
parent62e7a5220a607302963ebfa704cc101999b5daae (diff)
gnu: Add python-pytest-mypy-testing.
* gnu/packages/check.scm (python-pytest-mypy-testing): New variable. Change-Id: Ic55e63745eae070e439155f1dc6792285eb87312
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/check.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index ccc1aee0c5..d4ff9ea98b 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -3018,6 +3018,26 @@ a Pytest test execution.")
mypy plugins.")
(license license:expat)))
+(define-public python-pytest-mypy-testing
+ (package
+ (name "python-pytest-mypy-testing")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-mypy-testing" version))
+ (sha256
+ (base32 "0kqb3hi4jrc4knhc9pxv44m7c1jjkkwqx0dyghq4mw6wphlsv3q8"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-flit-core))
+ (propagated-inputs (list python-mypy python-pytest))
+ (home-page "https://github.com/davidfritzsche/pytest-mypy-testing")
+ (synopsis "Pytest plugin to check mypy output")
+ (description "This package provides a pytest plugin to test that mypy
+produces a given output. As mypy can be told to display the type of an
+expression this allows you to check mypys type interference.")
+ (license (list license:expat license:asl2.0))))
+
(define-public python-pytest-pep8
(package
(name "python-pytest-pep8")