summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-07 09:37:59 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:05 +0000
commit7cd548517f02605f0b1ac8c586fa363ea1303041 (patch)
treeb89d489c718197fce59b24ffb1a4c129847e7dc1 /gnu
parent98101729837efa32843d8e584213e0df81faf3bd (diff)
gnu: python-ewah-bool-utils: Update to 1.2.2.
* gnu/packages/python-compression.scm (python-ewah-bool-utils): Update to 1.2.2. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: I95840551cde83d0b74898eccb14b38d50edbc842
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-compression.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/python-compression.scm b/gnu/packages/python-compression.scm
index 1838d97a0d..15eaae5bdc 100644
--- a/gnu/packages/python-compression.scm
+++ b/gnu/packages/python-compression.scm
@@ -204,13 +204,13 @@ following algorithms are available:
(define-public python-ewah-bool-utils
(package
(name "python-ewah-bool-utils")
- (version "1.2.0")
+ (version "1.2.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "ewah_bool_utils" version))
(sha256
- (base32 "1bff3cv5m4n5pwqz0q90dy42vpyrrhylnrkcd49g1dlf3fs6r0pp"))))
+ (base32 "1hvs1fvf3g7kq6hnzxyxfrwvmykw503cmxf1l3irs67gr931z47b"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -220,7 +220,10 @@ following algorithms are available:
(lambda _
(invoke "python" "setup.py" "build_ext" "--inplace"))))))
(native-inputs
- (list python-cython python-pytest))
+ (list python-cython
+ python-pytest
+ python-setuptools
+ python-wheel))
(propagated-inputs
(list python-numpy))
(home-page "https://github.com/yt-project/ewah_bool_utils")