summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-02-26 17:50:45 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:30 +0000
commit52813c9e985e485cde9a3be5d1be7ce30af55db5 (patch)
treed5dae276e1f7dcd10eafaa50cc09523194e9b610 /gnu
parent3c438634192970984cdb2c7dc2627a2158fc92b9 (diff)
gnu: python-sphinx: Update to 6.2.1.
* gnu/packages/sphinx.scm (python-sphinx): Update to 6.2.1. [arguments]: Only disable one test. [propagated-inputs]: Add texlive-booktabs. (python-sphinx-5): New variable, inherit from python-sphinx. Change-Id: I95144924c4c0f293993bfbd7b644c378dd160077
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/sphinx.scm107
1 files changed, 99 insertions, 8 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 851e18036e1..292eaef9d07 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -47,6 +47,7 @@
#:use-module (guix build-system pyproject)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
+ #:use-module (gnu packages certs)
#:use-module (gnu packages check)
#:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
@@ -68,6 +69,103 @@
(define-public python-sphinx
(package
(name "python-sphinx")
+ (version "6.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Sphinx" version))
+ (sha256
+ (base32
+ "0sycp5qx7py75fvmjz0av5awfdlqn72azzjj07x9yx5vjx3a6mkd"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ ;; These require Internet access.
+ #~(list "-k" (string-append "not test_latex_images"
+ " and not test_build_latex_doc[lualatex-manual]"
+ " and not est_build_latex_doc[lualatex-howto]"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; for test_cython
+ (setenv "HOME" "/tmp"))))))
+ (propagated-inputs
+ (list python-babel
+ python-colorama
+ python-docutils
+ python-filelock
+ python-flake8
+ python-html5lib
+ python-imagesize
+ python-importlib-metadata
+ python-isort
+ python-jinja2
+ python-mypy
+ python-packaging
+ python-pygments
+ python-requests
+ python-snowballstemmer
+ python-sphinx-alabaster-theme
+ python-sphinxcontrib-applehelp
+ python-sphinxcontrib-devhelp
+ python-sphinxcontrib-htmlhelp
+ python-sphinxcontrib-jsmath
+ python-sphinxcontrib-qthelp
+ python-sphinxcontrib-serializinghtml
+ python-sphinxcontrib-websupport
+ python-types-requests
+
+ ;; The Sphinx LaTeX library '\RequirePackage' or \\usepackage
+ ;; these:
+ texlive-amsfonts ;amsmath, amssymb, amstext
+ texlive-amsmath
+ texlive-anyfontsize
+ texlive-booktabs
+ texlive-capt-of
+ texlive-carlisle ;remreset
+ texlive-cmap
+ texlive-etoolbox
+ texlive-fancyhdr
+ texlive-fancyvrb
+ texlive-float
+ texlive-fncychap
+ texlive-framed
+ texlive-geometry
+ texlive-hyperref
+ texlive-kvoptions
+ texlive-latex-bin
+ texlive-ltxcmds
+ texlive-needspace
+ texlive-oberdiek ;hypcap
+ texlive-parskip
+ texlive-preview
+ texlive-tabulary
+ texlive-titlesec
+ texlive-tools ;multicol, longtable
+ texlive-upquote
+ texlive-varwidth
+ texlive-wrapfig
+ texlive-xcolor))
+ (native-inputs
+ (list imagemagick ;for "convert"
+ nss-certs-for-test
+ python-cython
+ python-flit-core
+ python-pytest
+ (texlive-updmap.cfg
+ (list texlive-cm-super texlive-tex-gyre))))
+ (home-page "https://www.sphinx-doc.org")
+ (synopsis "Python documentation generator")
+ (description "Sphinx is a tool that makes it easy to create documentation
+for Python projects or other documents consisting of multiple reStructuredText
+sources.")
+ (license license:bsd-2)))
+
+(define-public python-sphinx-5
+ (package
+ (inherit python-sphinx)
(version "5.3.0")
(source
(origin
@@ -76,7 +174,6 @@
(sha256
(base32
"1dclwwz5rsvlw5rzyad1ar7i0zh4csni6jfp0lyc37zzm7h6s0ji"))))
- (build-system pyproject-build-system)
(arguments
(list
#:test-flags
@@ -158,13 +255,7 @@
python-flit-core
python-pytest
(texlive-updmap.cfg
- (list texlive-cm-super texlive-tex-gyre))))
- (home-page "https://www.sphinx-doc.org")
- (synopsis "Python documentation generator")
- (description "Sphinx is a tool that makes it easy to create documentation
-for Python projects or other documents consisting of multiple reStructuredText
-sources.")
- (license license:bsd-2)))
+ (list texlive-cm-super texlive-tex-gyre))))))
;; Some packages do not support Sphinx 5 yet. Remove when unused.
(define-public python-sphinx-4