summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-07-06 23:18:47 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:15:39 +0000
commit1269e01d3ef5fe3b877b6b5caa97b6a02c5675e4 (patch)
tree5592840d8931c6e16437035844d977caa1acd54b /gnu
parent0787a180b3ca64d3958438920ca1b58a2a27fba4 (diff)
gnu: python-pygments: Update to 2.15.1.
* gnu/packages/python-xyz.scm (python-pygments): Update to 2.15.1. [build-system]: Use pyproject-build-system. [arguments]: Run tests. [native-inputs]: Add python-pytest.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a999748d90f..ea34a5b1f3e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7219,18 +7219,23 @@ with Python.")
(define-public python-pygments
(package
(name "python-pygments")
- (version "2.12.0")
+ (version "2.15.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Pygments" version))
(sha256
(base32
- "1sr6iqh21xi6p8aba4wa9pqfhjbbpcvn9jcsx0ggy4lniw8idcay"))))
- (build-system python-build-system)
+ "0p3p28fif7m2w5mkd0z99zk9xwgrs3m61x85415qk0fl3ly4vkla"))))
+ (build-system pyproject-build-system)
(arguments
- ;; FIXME: Tests require sphinx, which depends on this.
- '(#:tests? #f))
+ (list
+ #:test-flags
+ ;; Some tests require sphinx, which depends on this, so we only run
+ ;; basic tests.
+ '(list "--ignore-glob=tests/*/*")))
+ (native-inputs
+ (list python-pytest))
(home-page "https://pygments.org/")
(synopsis "Syntax highlighting")
(description