summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-10-14 23:51:29 +0300
committerArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-10-15 22:54:54 +0300
commitf5ae687319852ed3eca6bb83a139a2a9e71cbfe9 (patch)
tree4ee36093b3596ec99ca809c8c01f943d3678274b /gnu
parent377359315fbb0e1414354910ba3a14c145fdc519 (diff)
gnu: Add go-github-com-kpango-fastime.
* gnu/packages/golang-xyz.scm (go-github-com-kpango-fastime): New variable. Change-Id: I79bf2cd7d0a3a29d2718788184560c0cfe406e4f
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 942c5f5138..a616b1f47f 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4061,6 +4061,30 @@ very eas to use.")
(list
#:import-path "github.com/klauspost/cpuid/v2"))))
+(define-public go-github-com-kpango-fastime
+ (package
+ (name "go-github-com-kpango-fastime")
+ (version "1.1.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kpango/fastime")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "18f1p5wf0zf73ky0h2hqfa6b6zryf7pq7k2r02if673x7bjlbp9h"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/kpango/fastime"))
+ (home-page "https://github.com/kpango/fastime")
+ (synopsis "Fast time function library for Go")
+ (description
+ "@code{fastime} is a time function library for Go with zero memory
+allocation. @code{fastime} is returning the approximate time.")
+ (license license:expat)))
+
(define-public go-github-com-kr-pretty
(package
(name "go-github-com-kr-pretty")