summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-09 15:06:13 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-18 11:36:25 +0300
commitf5adeabdf66248988cd7089e57b734c1cba3ad47 (patch)
tree00e661faf1624a1e629cb29c9ef11e8bb56aa673 /gnu
parentf44309053a537f8765bca4fd91c4c34f025a1dd4 (diff)
gnu: rust-serde-repr-0.1: Update to 0.1.16.
* gnu/packages/crates-io.scm (rust-serde-repr-0.1): Update to 0.1.16. [cargo-inputs]: Replace rust-proc-macro2-1.0.34 with 1, rust-quote-1.0.10 with 1, rust-syn-1 with 2. [cargo-development-inputs]: Replace rust-serde-json-1.0.73 with 1, rust-trybuild-1.0.19 with 1.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1b8d6b0473..871fd2e90a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -62452,25 +62452,25 @@ commonly used by Ruby on Rails via Rack.")
(define-public rust-serde-repr-0.1
(package
(name "rust-serde-repr")
- (version "0.1.10")
+ (version "0.1.16")
(source
(origin
(method url-fetch)
(uri (crate-uri "serde_repr" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0knbzc87nlrfnm1jh3zmx77hxflnzk0xl8xcv7jvn3m2fkxcjpls"))))
+ (base32 "005x2q9x6cdqp312mjhggbzd6vkg8r0abcg0biz0z9dkmpgy29c7"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
- (("rust-proc-macro2" ,rust-proc-macro2-1.0.34)
- ("rust-quote" ,rust-quote-1.0.10)
- ("rust-syn" ,rust-syn-1))
+ (("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-2))
#:cargo-development-inputs
(("rust-rustversion" ,rust-rustversion-1)
("rust-serde" ,rust-serde-1)
- ("rust-serde-json" ,rust-serde-json-1.0.73)
- ("rust-trybuild" ,rust-trybuild-1.0.19))))
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-trybuild" ,rust-trybuild-1))))
(home-page "https://github.com/dtolnay/serde-repr")
(synopsis "Serialize and deserialize C-like enum as underlying repr")
(description