summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-12-18 10:32:04 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-12-18 15:26:34 +0200
commitbff32e20e72cd4d74f294e2f6d87512921554d3d (patch)
treef8cfc2dc51c57f24b77076bd72e77fd93562e822 /gnu
parent3e096a6babf7d5f07141a5ea1f8239a9fd96932d (diff)
gnu: glib: Fix build on powerpc-linux.
* gnu/packages/glib.scm (glib)[arguments]: When building for powerpc-linux skip another test. Change-Id: Ibc3d166ce8d60119ae7c0a1874ab0bdfada44921
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/glib.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index a15a7ce58a..0effc87f45 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2021 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016, 2020, 2021, 2023 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2020, 2021, 2023, 2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
;;; Copyright © 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Petter <petter@mykolab.ch>
@@ -328,6 +328,12 @@ information, refer to the @samp{dbus-daemon(1)} man page.")))
(("^ g_assert_cmpfloat \\(elapsed, ==.*" all)
(string-append "//" all "\n"))))
'())
+ #$@(if (target-ppc32?)
+ ;; assertion failed (last_thread_id <= thread_id): (3 <= 2)
+ #~((substitute* "glib/tests/thread-pool-slow.c"
+ (("^ g_assert_cmpint \\(last_thread_id.*" all)
+ (string-append "//" all "\n"))))
+ #~())
#$@(if (system-hurd?)
'((with-directory-excursion "gio/tests"
;; TIMEOUT after 600s