summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSimon Tournier <zimon.toutoune@gmail.com>2024-09-05 17:34:48 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-08 21:04:58 +0900
commitacba6223b5268ece0c6cb4b1ce346f5dc5e8affc (patch)
tree702b9663c6c198449a3634c9e36e731ef97cbf02 /gnu
parent43df0d8308a32ce76fcd57003a98739ec67360e3 (diff)
gnu: git: Fix perl search-paths of wrapped programs.
Fixes a regression introduced in f288604428e9c8f096ec9e0eccf207e079806271, where the git-send-email and gitweb.cgi wrap-programs had been translated into the "new style" using G-exps. * gnu/packages/version-control.scm (git)[arguments]<phases>: Restore the complete list of propagated inputs by modifying the functional composition order. Fixes: https://issues.guix.gnu.org/73030 Change-Id: Ia4e5feeae6418a9f098464556b74bc871e761be1 Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/version-control.scm27
1 files changed, 18 insertions, 9 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 1db783b731..23f59e281a 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -55,6 +55,7 @@
;;; Copyright © 2024 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2024 Suhail Singh <suhail@bayesians.ca>
+;;; Copyright © 2024 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -657,21 +658,29 @@ everything from small to very large projects with speed and efficiency.")
,(search-path-as-list
'("lib/perl5/site_perl")
'#$(delete-duplicates
- (append-map
- (compose last package-transitive-propagated-inputs)
- (list (this-package-input "perl-authen-sasl")
- (this-package-input "perl-net-smtp-ssl")
- (this-package-input
- "perl-io-socket-ssl")))))))
+ (let ((perl-inputs
+ (list (this-package-input "perl-authen-sasl")
+ (this-package-input "perl-net-smtp-ssl")
+ (this-package-input "perl-io-socket-ssl"))))
+ (append perl-inputs
+ (map last
+ (append-map
+ package-transitive-propagated-inputs
+ perl-inputs))))))))
+
;; Tell 'gitweb.cgi' where perl modules are.
(wrap-program (string-append out "/share/gitweb/gitweb.cgi")
`("PERL5LIB" ":" prefix
,(search-path-as-list
'("lib/perl5/site_perl")
'#$(delete-duplicates
- (append-map
- (compose last package-transitive-propagated-inputs)
- (list (this-package-input "perl-cgi")))))))
+ (let ((perl-inputs (list (this-package-input
+ "perl-cgi"))))
+ (append perl-inputs
+ (map last
+ (append-map
+ package-transitive-propagated-inputs
+ perl-inputs))))))))
;; Tell 'git-submodule' where Perl is.
(wrap-program git-sm