summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-10-14 23:58:56 +0300
committerArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-10-15 22:55:01 +0300
commit8ffb0c14b8abdbb471788f993a7835add147e3a8 (patch)
tree3e1d039be51c410f6bc6c43f737283b8788ed056 /gnu
parentf5ae687319852ed3eca6bb83a139a2a9e71cbfe9 (diff)
gnu: Add go-github-com-kpango-glg.
* gnu/packages/golang-xyz.scm (go-github-com-kpango-glg): New variable. Change-Id: Iaa457f5a53000713df0a7fad3f772e57143c9d1c
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index a616b1f47f..e8b7f7ee9f 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4061,6 +4061,34 @@ very eas to use.")
(list
#:import-path "github.com/klauspost/cpuid/v2"))))
+(define-public go-github-com-kpango-glg
+ (package
+ (name "go-github-com-kpango-glg")
+ (version "1.6.15")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kpango/glg")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0k6y8nvj0q8mz362490cmcx15rhcpyx4sf4rv153dgh46acd1phh"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/kpango/glg"))
+ (propagated-inputs
+ (list go-github-com-goccy-go-json
+ go-github-com-kpango-fastime
+ go-github-com-sirupsen-logrus
+ go-go-uber-org-zap))
+ (home-page "https://github.com/kpango/glg")
+ (synopsis "Lock-free logging library for Go")
+ (description
+ "@code{glg} is simple lock-free logging library for Go.")
+ (license license:expat)))
+
(define-public go-github-com-kpango-fastime
(package
(name "go-github-com-kpango-fastime")