summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2025-01-13 17:02:09 +0800
committer宋文武 <iyzsong@member.fsf.org>2025-01-14 19:10:55 +0800
commit819c3feb0e1c8324e05916db15a8ae2e60b08aaa (patch)
tree5c60ba4d8c045fa39d4219234154d119d0c06438 /gnu
parentf650fa36eee32817509b4c1a306d8a00ec054e7a (diff)
gnu: lxqt-powermanagement: Update to 2.1.0.
* gnu/packages/lxqt.scm (lxqt-powermanagement): Update to 2.1.0. [inputs]: Simplify. Change-Id: I988a275473c33ce21cd2f0a0b9a1da284382f783
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lxqt.scm15
1 files changed, 5 insertions, 10 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 7535410c39..d8be260ea7 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -584,27 +584,22 @@ LXQt.")
(define-public lxqt-powermanagement
(package
(name "lxqt-powermanagement")
- (version "1.3.0")
+ (version "2.1.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "17d1wh50pjjzqyxv3w7b4qlc1ym1p16yvbhyah9bzl2825irz9ar"))))
+ (base32 "0pyzd7pw3mpp0f5193a8fg1bvixwabrapnpqy2q2a707j664mqhj"))))
(build-system cmake-build-system)
(inputs
- (list kidletime-5
- kwindowsystem-5
+ (list kidletime
liblxqt
- libqtxdg
lxqt-globalkeys
- qtbase-5
- qtsvg-5
- qtx11extras
- solid-5))
+ solid))
(native-inputs
- (list lxqt-build-tools qttools-5))
+ (list lxqt-build-tools))
(arguments '(#:tests? #f)) ; no tests
(home-page "https://lxqt-project.org")
(synopsis "Power management module for LXQt")