summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-12 18:54:10 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-18 11:36:30 +0300
commit80c69940dba5b077b19a92d47c8f8999453d0970 (patch)
tree9c09692400e0c746e9e626f8dae8f8e7c55d5ab8 /gnu
parent48e0a41d32c3cb1641069d1c9338739252dacbd9 (diff)
gnu: rust-rustfix-0.6: Update to 0.6.1.
* gnu/packages/crates-io.scm (rust-rustfix-0.6): Update to 0.6.1. [arguments]: Skip build. [cargo-inputs]: Add rust-anyhow-1, rust-log-0.4, rust-serde-1, rust-serde-json-1.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 117b3aa1fe9..49c6a017887 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -58717,17 +58717,22 @@ rustc compiler.")
(define-public rust-rustfix-0.6
(package
(name "rust-rustfix")
- (version "0.6.0")
+ (version "0.6.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "rustfix" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32
- "0apkjxv3z70vhnyz2kpwsivvndk6qk7kkp0rf7sg8pk7q1gy02vg"))))
+ (base32 "10b4qlvfwljp7yss8afj0lnn8vqj78n93n9vfmkq9616kqyqblpc"))))
(build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t ; Cut the dependency chain here
+ #:cargo-inputs
+ (("rust-anyhow" ,rust-anyhow-1)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1))))
(home-page "https://github.com/rust-lang/rustfix")
(synopsis "Automatically apply the suggestions made by rustc")
(description "Automatically apply the suggestions made by rustc.")