summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGabriel Wicki <gabriel@erlikon.ch>2025-01-05 20:25:33 +0100
committerLudovic Courtès <ludo@gnu.org>2025-01-07 17:54:04 +0100
commit700a6ebf3d3b75d4fab4a496565a3da63aee36fa (patch)
tree598d283e833f46c51d14de98a360f28b0850d143 /gnu
parente94d35e522aa10ab715b53bce91ed397f59b9bd9 (diff)
gnu: hunspell: Add Swiss German dictionary.
* gnu/packages/hunspell.scm(hunspell-dict-de-ch): New variable. Change-Id: Ib868e7efaa92e536229d45098ffd8f38a9441b83 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/hunspell.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/hunspell.scm b/gnu/packages/hunspell.scm
index eed10b16bb3..73092d6839e 100644
--- a/gnu/packages/hunspell.scm
+++ b/gnu/packages/hunspell.scm
@@ -219,6 +219,39 @@ spell-checking library.")
(home-page "https://www.j3e.de/ispell/igerman98/")
(license (list license:gpl2 license:gpl3))))
+(define-public hunspell-dict-de-ch
+ (package
+ (name "hunspell-dict-de-ch")
+ (version "20161207")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.j3e.de/ispell/igerman98/dict/"
+ "igerman98-" version ".tar.bz2"))
+ (sha256
+ (base32 "1a3055hp2bc4q4nlg3gmg0147p3a1zlfnc65xiv2v9pyql1nya8p"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags '("hunspell/de_CH.dic")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install ;no install target
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (share (string-append out "/share/hunspell/")))
+ (install-file "hunspell/de_CH.aff" share)
+ (install-file "hunspell/de_CH.dic" share)
+ #t))))
+ #:tests? #f)) ; no tests
+ (native-inputs
+ (list hunspell ispell perl))
+ (synopsis "Hunspell dictionary for Swiss German (de_CH)")
+ (description "This package provides a dictionary for the Hunspell
+spell-checking library.")
+ (home-page "https://www.j3e.de/ispell/igerman98/")
+ (license (list license:gpl2 license:gpl3))))
+
(define-public hunspell-dict-hu
(let ((revision "2")
(major+minor "1.7"))