summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSpencer King <spencer.king@geneoscopy.com>2025-01-06 20:50:12 +0000
committerLudovic Courtès <ludo@gnu.org>2025-01-12 18:48:15 +0100
commit59646be90383d275f47bcb8acdefe1ea9bdbb90a (patch)
tree1b28069334d60b9645e090588e40b1cfad7d04b0 /gnu
parent1c821f620a266e1c37dc06240d7a45b26f350617 (diff)
gnu: Add julia-manualmemory.
* gnu/packages/julia-xyz.scm (julia-manualmemory): New variable. Change-Id: I8a5b2c1fb9dfa0b83864023ba71a2cb74fee1d8f Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index a7a6081e2f..a1e6879da0 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -4288,6 +4288,31 @@ expressions. This includes a template-matching system and code-walking tools
that let you do deep transformations of code.")
(license license:expat)))
+(define-public julia-manualmemory
+ (package
+ (name "julia-manualmemory")
+ (version "0.1.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaSIMD/ManualMemory.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ajd92q65cffyb9x6mb1x1aprr2afn8p52bfkbmf303dy5ac63lj"))))
+ (build-system julia-build-system)
+ ;; Tests have a dependency cycle with VectorizationBase
+ ;; VectorizationBase -> LayoutPointers -> ManualMemory -> VectorizationBase
+ (arguments
+ (list
+ #:tests? #f))
+ (home-page "https://github.com/JuliaSIMD/ManualMemory.jl")
+ (synopsis "Manual memory management utilities in Julia")
+ (description "This package provides manually managed memory buffers backed
+by @code{NTuples} in Julia.")
+ (license license:expat)))
+
(define-public julia-mappedarrays
(package
(name "julia-mappedarrays")