summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-11-14 21:38:00 +0300
committerArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-11-22 18:59:17 +0300
commit507c9da4e6c1e5087f981af3292995f007eed29d (patch)
tree93939726a7fe3a813cb04f303d266a211509b9bd /gnu
parent2fec407b2745898d0a304c172a27dfe0a8787122 (diff)
gnu: Add go-github-com-caddyserver-zerossl.
* gnu/packages/golang-web.scm (go-github-com-caddyserver-zerossl): New variable. Change-Id: Ibec80ae2d4d86f99f8bc271a1c4dfd2591d66290 Reviewed-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-web.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 6e47aef039b..02a0c5e331d 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -641,6 +641,33 @@ Manager,NTLM}/Negotiate authentication over HTTP.")
"This package provides SCSS compiler support for Go applications.")
(license license:expat)))
+(define-public go-github-com-caddyserver-zerossl
+ (package
+ (name "go-github-com-caddyserver-zerossl")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/caddyserver/zerossl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0hr2kdabhm35hz5krp7m3g6wxvyb9xlqgmy3krf4wwb3yabsqp1m"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/caddyserver/zerossl"))
+ (home-page "https://github.com/caddyserver/zerossl")
+ (synopsis "ZeroSSL REST API client implementation for Go")
+ (description
+ "@code{zerossl} implements the @url{https://zerossl.com/documentation/api/,
+ZeroSSL REST API}.
+
+The REST API is distinct from the @url{https://zerossl.com/documentation/acme/, ACME
+endpoint}, which is a standardized way of obtaining certificates.")
+ (license license:expat)))
+
(define-public go-github-com-ccding-go-stun
(package
(name "go-github-com-ccding-go-stun")