summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-07-12 14:00:05 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-19 16:15:05 +0200
commit4dc1442cc1eaf7265b277901474de2d82a0089e7 (patch)
treecc4b186ae97739cfda63066bf8a0a6fbdb1ffe05 /gnu
parent208c296f96a8c1d085da7d67404e5f1bd48e5f54 (diff)
gnu: openmpi: Set default version to 4.x.
* gnu/packages/mpi.scm (openmpi-4): New variable. (openmpi): Redefine variable. Change-Id: If5bb4429c935982ddaa1a5acbd728367ebbfd6fd Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mpi.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index f80ec8b78e..bca215df47 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -188,7 +188,7 @@ bind processes, and much more.")
;; The latest stable series of hwloc.
hwloc-2)
-(define-public openmpi
+(define-public openmpi-4
(package
(name "openmpi")
(version "4.1.6")
@@ -312,6 +312,8 @@ software vendors, application developers and computer science researchers.")
;; See file://LICENSE
(license license:bsd-2)))
+(define-public openmpi openmpi-4)
+
(define-public openmpi-5
(package
(inherit openmpi)