summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2025-01-12 13:24:14 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:45 +0100
commit4753d8f61bce69267124997571336d88a68a6503 (patch)
tree448c22cbc6278d77cf33eafa39c34ba69402f623 /gnu
parentd19bd45ce91f2ac9792b16fe22eee9b11ecb8f21 (diff)
gnu: python-django-filter: Update to 24.3.
* gnu/packages/django.scm (python-django-filter): Update to 24.3. [build-system]: Use pyproject-build-system. [arguments]: Make tests conditional. [native-inputs]: Remove python-django-crispy-forms and python-mock; add python-flit-core and tzdata-for-tests. Change-Id: I0a7273747d53013c7aef5c1674d957223c399e21
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/django.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 8364df3943..f6b687945d 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -531,23 +531,26 @@ your code.")
(define-public python-django-filter
(package
(name "python-django-filter")
- (version "2.3.0")
+ (version "24.3")
(source (origin
(method url-fetch)
- (uri (pypi-uri "django-filter" version))
+ (uri (pypi-uri "django_filter" version))
(sha256
(base32
- "1bz5qzdk9pk4a2lp2yacrdnqmkv24vxnz4k3lykrnpc3b7bkvrhi"))))
- (build-system python-build-system)
+ "1hyr5i5f4n5kk5ax3y39hslhy0wi2nqk6rrgajh1rlmg69kszk6q"))))
+ (build-system pyproject-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "python" "runtests.py"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "runtests.py")))))))
(native-inputs
- (list python-django python-django-rest-framework
- python-django-crispy-forms python-mock))
+ (list python-django
+ python-django-rest-framework
+ python-flit-core
+ tzdata-for-tests))
(home-page "https://django-filter.readthedocs.io/en/latest/")
(synopsis "Reusable Django application to filter querysets dynamically")
(description