summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEvgeny Pisemsky <mail@pisemsky.site>2024-11-18 22:47:17 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-18 22:47:17 +0000
commit4473f8ae902c2192cab6919363a9101ce9861e45 (patch)
treebe290cc3338070a4553fd3e28127a30bf1c671b2 /gnu
parentc9d60ff8233e626b10780b2a1666634f5bcee56f (diff)
gnu: Add python-svgelements.
* gnu/packages/python-xyz.scm (python-svgelements): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: Ic42dc142ba63ccf8c1bfa72a69b43afd7344b327
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0156d311e8..c7d2efe79f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -157,6 +157,7 @@
;;; Copyright © 2024 Rick Huijzer <ikbenrickhuyzer@gmail.com>
;;; Copyright © 2024 Peter Kannewitz <petre-vps@posteo.net>
;;; Copyright © 2024 Aaron Covrig <aaron.covrig.us@ieee.org>
+;;; Copyright © 2024 Evgeny Pisemsky <mail@pisemsky.site>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32224,6 +32225,33 @@ For the most part it's transliterated from C, the major differences are:
"Jinxed is an implementation of a subset of the Python curses library.")
(license license:mpl2.0)))
+(define-public python-svgelements
+ (package
+ (name "python-svgelements")
+ (version "1.9.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "svgelements" version))
+ (sha256
+ (base32 "1xrp7yxg65dqdrmghriljf9hh2smq2zhzr2hzmqifgfd0ijas0kw"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-anyio
+ python-pytest
+ python-numpy
+ python-pillow
+ python-scipy
+ python-setuptools
+ python-wheel))
+ (home-page "https://github.com/meerk40t/svgelements")
+ (synopsis "SVG parsing for elements, paths, and other SVG objects")
+ (description
+ "This module does high fidelity SVG parsing and geometric rendering.
+The goal is to successfully and correctly process SVG for use with any scripts
+that may need or want to use SVG files as geometric data.")
+ (license license:expat)))
+
(define-public python-svgutils
(package
(name "python-svgutils")