summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@posteo.net>2024-11-19 23:12:24 -0600
committerEric Bavier <bavier@posteo.net>2024-11-20 00:02:45 -0600
commit1daad52eac9df75dd61108b85ede3066eb653e63 (patch)
treeb95bf56c610e4af132f1ea6a83b5688ff88c4100 /gnu
parent1e6d1c32117e9f731e50dcd286927a5fa0d17afc (diff)
gnu: Add python-pytest-check.
* gnu/packages/python-check.scm (python-pytest-check): New variable. Change-Id: Idfa08578c9ad23b644f842abc93455dd72970fc2
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-check.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 7f8e96c311..8599d8bf1d 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;; Copyright © 2024 Navid Afkhami <navid.afkhami@mdc-berlin.de>
;;; Copyright © 2024 David Elsing <david.elsing@posteo.net>
+;;; Copyright © 2024 Eric Bavier <bavier@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1199,6 +1200,25 @@ representations of doctest results. It can change the display hook used by
doctest to render the object representations.")
(license license:expat)))
+(define-public python-pytest-check
+ (package
+ (name "python-pytest-check")
+ (version "2.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest_check" version))
+ (sha256
+ (base32 "0l7n2jhadbkmqr8kzja8zwclhjvhc87qsgr5v867zgsry37fy92j"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-flit-core))
+ (propagated-inputs (list python-pytest))
+ (home-page "https://github.com/okken/pytest-check")
+ (synopsis "Pytest plugin to allow multiple failures")
+ (description "This package provides a pytest plugin that allows multiple
+failures per test.")
+ (license license:expat)))
+
(define-public python-pytest-checkdocs
(package
(name "python-pytest-checkdocs")